0
xefil

BananaPi AllWinner A20 - Enable UART/Serial

Recommended Posts

Armbianmonitor:

Hi all,

I've a bananapi 1 and would like to follow this guide to attach to my board directly a Zigbee device CC2530+CC2591: https://www.zigbee2mqtt.io/information/connecting_cc2530.html#wiring-cc2530-to-the-raspberry

Then, I've connected it using exactly the same schema, which should be the same on BananaPi, based on http://wiki.lemaker.org/File:Banana_Pro_CON6_Definetion.png

 

VCC -> 3,3V (Pin1)
GND -> GND (Pin6)
P02 -> TXD (Pin8)
P03 -> RXD (Pin10)

Then, I've tried to connect to serial via minicom:

 

minicom -b 115200 -o -D /dev/ttyS2

 

BTW I'm not getting any info from the device, so what I'm doing wrong?

I've then enabled via armbian-config the UART2 and rebooted, but nothing changed.

Previously this device was attached on an ESP8266 and was working, so I think it's not a device option.

 

Could someone help me?

 

Many thanks!

 

Simon

 

Share this post


Link to post
Share on other sites
2 hours ago, xefil said:

I've then enabled via armbian-config the UART2 and rebooted, but nothing changed.

Check "dmesg | grep tty" because, for example, if UART1 is not enabled, then UART2 will be assigned to /dev/ttyS1 not S2 ...

Share this post


Link to post
Share on other sites

Hello,

 

Could this help?

 

root@zigbee2mqtt:~                                                                                                                                                                       
▶ ls -al /sys/bus/platform/devices/|grep -i serial
lrwxrwxrwx 1 root root 0 Mar 19 08:59 1c28000.serial -> ../../../devices/platform/soc/1c28000.serial
lrwxrwxrwx 1 root root 0 Mar 19 08:59 1c28800.serial -> ../../../devices/platform/soc/1c28800.serial
lrwxrwxrwx 1 root root 0 Mar 19 08:59 1c28c00.serial -> ../../../devices/platform/soc/1c28c00.serial
lrwxrwxrwx 1 root root 0 Mar 19 08:59 1c29c00.serial -> ../../../devices/platform/soc/1c29c00.serial
lrwxrwxrwx 1 root root 0 Mar 19 08:59 serial8250 -> ../../../devices/platform/serial8250

root@zigbee2mqtt:~                                                                                                                                                                       
▶ dmesg | grep -i 'uart\|serial\|tty'
[    0.000000] Kernel command line: root=UUID=ca5b442b-ad1b-4f97-a943-4a1eff347c75 rootwait rootfstype=ext4 console=ttyS0,115200 console=tty1 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 panic=10 consoleblank=0 loglevel=1 ubootpart=1406e616-01 ubootsource=mmc usb-storage.quirks=0x2537:0x1066:u,0x2537:0x1068:u   sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16 cgroup_enable=memory swapaccount=1
[    0.001173] printk: console [tty1] enabled
[    2.941834] Serial: 8250/16550 driver, 8 ports, IRQ sharing disabled
[    2.944511] printk: console [ttyS0] disabled
[    2.964746] 1c28000.serial: ttyS0 at MMIO 0x1c28000 (irq = 49, base_baud = 1500000) is a U6_16550A
[    2.964816] printk: console [ttyS0] enabled
[    2.988020] 1c28800.serial: ttyS1 at MMIO 0x1c28800 (irq = 50, base_baud = 1500000) is a U6_16550A
[    3.009176] 1c28c00.serial: ttyS2 at MMIO 0x1c28c00 (irq = 51, base_baud = 1500000) is a U6_16550A
[    3.032081] 1c29c00.serial: ttyS3 at MMIO 0x1c29c00 (irq = 52, base_baud = 1500000) is a U6_16550A
[    9.312286] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    9.312307] usb usb1: SerialNumber: 1c14000.usb
[    9.332249] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    9.332269] usb usb2: SerialNumber: 1c1c000.usb
[    9.416969] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    9.416991] usb usb3: SerialNumber: 1c14400.usb
[    9.492300] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    9.492322] usb usb4: SerialNumber: 1c1c400.usb
[    9.508528] usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    9.508549] usb usb5: SerialNumber: musb-hdrc.1.auto

I've tried all serial ports manually, no luck.

 

Thanks!

 

Simon

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0