0
xwiggen

sed: no input files (armbian-hardware-optimization)

Recommended Posts

--- armbian-hardware-optimization.orig  2020-05-17 10:53:46.352578716 +0200
+++ armbian-hardware-optimization       2020-05-17 10:54:02.052970679 +0200
@@ -67,7 +67,7 @@
        [[ -f $prefix/cpuinfo_cur_freq ]] && chmod +r $prefix/cpuinfo_cur_freq 2> /dev/null

        # enable compression where not exists
-       find /etc/logrotate.d/. -type f | xargs grep -H -c 'compress' | grep 0$ | cut -d':' -f1 | xargs -L1 sed -i '/{/ a compress'
+       find /etc/logrotate.d/. -type f | xargs grep -H -c 'compress' | grep 0$ | cut -d':' -f1 | xargs -L1 sed -i '/{/ a compress' 2> /dev/null
        sed -i "s/#compress/compress/" /etc/logrotate.conf

        # tweak ondemand cpufreq governor settings to increase cpufreq with IO load

Share this post


Link to post
Share on other sites

sorry little cryptic;

 

sed: no input files

 

appears in log because it previously did its work :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0