Problems with Zram on H2/3/5 boards - zram: Decompression failed! err=-22


1 1
Go to solution Solved by Icenowy,

Recommended Posts


Good evening,


I ran into some problems with sbc-bench on a couple of Allwinner boards Orange Pi Zero, Orange Pi Zero+, Orange Pi One and Nanopi Neo 2 spcifically. The 7 Zip benchmark causes the following error:


./ Zeile 611:  4206 Bus-Zugriffsfehler      "${SevenZip}" b >> ${TempLog}


Most likely due to a problem with the ZRam:


zram: Decompression failed! err=-22


This happens on all boards under Debian and focal with different SD cards and power supplies. The benchmark ran previously on this setups without any issues – unfortunately I don’t know when it stopped working and hence cannot narrow down the change that caused the problem.


The benchmark results and armbianmonitor output from the Orange Pi one as an example:


Is this a known issue? Is there a solution?



Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Thanks for the info, is there any work around?


Switching to zstd caused the same error and crashed the board while benchmarking. After a reboot:  - Interestingly it says:

### Activated 1 lzo-rle zram swap devices with 491 MB each



root@orangepizero:~# zramctl


/dev/zram1 zstd        491,6M    4K    58B    4K       4 [SWAP]

/dev/zram0 zstd           50M  1,4M 184,1K  572K       4 /var/log



Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


1 1