Jump to content
  • 0

NanoPI Neo 2 first login error: /usr/bin/ckbcomp: Can not find file "symbols/mx" in any known directory


otlabs
 Share

Question

Armbianmonitor:

During first boot and following first login as root got this error message:

 

New to Armbian? Documentation: https://docs.armbian.com Support: https://forum.armbian.com

New root password: ************
Repeat password: ************
Detected timezone: America/Mexico_City (CST, -0600)
Generating locales: es_MX.UTF-8
Adding console keyboard layout: mx
/usr/bin/ckbcomp: Can not find file "symbols/mx" in any known directory

 

I am not sure that console keyborad layout "mx" exists.

 

 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

Donate and support the project!

  • 0

Now I see same error "/usr/bin/ckbcomp: Can not find file "symbols/mx" in any known directory" while running armbian-config

 

Starting armbian-config I get following warning:

 

otlabs@nanopineo2:~$ sudo armbian-config 
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (es_MX.UTF-8)

 

In main armbian-config I navigate to "Personal" and in "Keyboard" field I see "Change console keyboard layout (us,mx)". Selecting this option produces following output with errors (please, take a look at line in bold as it again mention "mx" keyboard layout):

 

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = "es_MX.UTF-8",
        LC_ALL = "es_MX.UTF-8", 
        LC_MESSAGES = "en_US.UTF-8",
        LANG = "es_MX.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C"). 
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.136ubuntu6.3) ...
update-initramfs: Generating /boot/initrd.img-5.8.16-sunxi64
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (es_MX.UTF-8)
update-initramfs: Converting to u-boot format
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
    LANGUAGE = "es_MX.UTF-8",
    LC_ALL = "es_MX.UTF-8",
    LC_MESSAGES = "en_US.UTF-8",
    LANG = "es_MX.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
/usr/bin/ckbcomp: Can not find file "symbols/mx" in any known directory
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

 

Link to comment
Share on other sites

  • 0
7 hours ago, otlabs said:

Now I see same error "/usr/bin/ckbcomp: Can not find file "symbols/mx" in any known directory" while running armbian-config


My fix is here to solve problems at first login - for the future, when we rebuild images. For now you also need to remove mx from /etc/default/keyboard and run setupcon -k --force

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...