Vontar x3


Recommended Posts

    Hi Everyone,

 

  I hope that some good and skilled guy can help me to solve my problem.

 

  According to some topics on this forum I decided to buy a vontar x3 because some of you said that it work fully on armbian after some tweaks.

 

  The problem is that even if I follow all of the guided steps caught on differents topics of this forum, my vontar x3 fall in an infinite reboot loop as long as I try to boot on my SD card with the toothpick method.

  Hereunder is the very simple methodology I follow - surely something is wrong but I don't know what it is... 

 

- I downloaded a bootstrap image of armbian on the armbian repo of balbes150 (https://users.armbian.com/balbes150/arm-64/) - the image is Armbian_20.10_Arm-64_bionic_current_5.9.0.img

- I mounted this image on my personal linux;

mount -o loop,offset=$((32768*512)) ~/xxxx.img /mnt/armbian-bionic

- I made a copy of the dtb files h96max-x3-test8.dtb and h96max-x2-test-bus80-gpu-volt.dtb [grabbed from the gdrive of root-stas] to /dtb/amlogic

- I modified the file extlinux/extlinux.conf to take into account one of this two previous dtb file :

 

FDT /dtb/amlogic/h96max-x3-test8.dtb
APPEND root=LABEL=ROOTFS rootflags=data=writeback rw console=ttyAML0,115200n8 console=tty0 no_console_suspend consoleblank=0 fsck.fix=yes fsck.repair=yes net.ifnames=0

- I made a copy of u-boot-s905x2-s922 to u-boot.ext (and u-boot.sd) [this step is ambiguous for me]

- I've unmounted my img

- I made a Bit2Bit copy to my sd card:

dd if=~/xxxx.img of=/dev/mmcblk0 bs=4M status=progress

- I switched off my vontar x3;

- I plugged my sd card into;

- I switched on my vontar x3 while maintening a pressure inside de Jack audio hole with a toothpick

- I release after somes seconds (maybe 5s) the pressure and...

- vontar x3 reboot and reboot and reboot and reboot ....

 

  Also, I see that someone (@ikbel) has the same problem with his vontar x3 at the end of another topic (h96-max-x3-specifics-only) but this topic was closed...

 

  I need your help guys.

 

  See you,

  Antoine.

Link to post
Share on other sites
Donate and support the project!

    Hi,

 

  thank you for all your replies.

  I think that I will follow the advice of @rodia and downgrade the firmware of my box.

  Now, I have to find a way to do that with my PC under linux (because I don't have windows at home) . I see that there are some software updater for Amlogic but they are all under windows...

  Anyway, thank you again and once I'll be able to downgrade my firmware I will give some news on this post for those that are interested.

 

  See you soon,

 

  Antoine

 

Link to post
Share on other sites

   Hi Guys,

 

  as stated before, I come back (with very good news ;))

  I follow the advice of @rodia and I did a firmware downgrade of my vontar X3 box to the april one (using linux because the card burner tool of windows didn't work as expected - it formatted my sd card to exFAT than Fat32) and now I can boot on Armbian bullseye 5.9 using the meson-sm1-hk1box-vontar-x3.dtb (thanks to @sag).

  After this step, all goes well and now I have a vontar X3 with a armbian installed on my EMMC, 1Gbs full-duplex ethernet, wifi and BT fully working!!!


  I hope  that this topic will help one day someone else.

 

  Again, a great THANKS to you guys, armbian and this forum!!

 

  Antoine

 

Link to post
Share on other sites

Hi everyone, this is my first post in this forum.

 

I have TV box Vontar X3 4G/64G

 

I copied u-boot-s905x2-s922 to u-boot.ext and u-boot.sd and I change extlinux/extlinux.conf with the reference to meson-sm1-hk1box-vontar-x3.dtb.

 

I tried all the images that are in https://users.armbian.com/balbes150/arm-64/ with meson-sm1-hk1box-vontar-x3.dtb that I donwloaded from. And all distros work well, but I don't have sound without any of them.  Do you have ideas?

 

(I have tried the image from  h96max-x2-test-bus80-gpu-volt.dtb with an older image. In this case I get sound with the distro but there is no 3D acceleration)

 

With the bulleye release works fine 3D drivers.

 

Thanks in advance!

 

 

Link to post
Share on other sites