Orange Pi One+ cannot communicate with UART3 on Armbian_21.02.1_Orangepioneplus_buster_current_5.10.12.img.xz


Recommended Posts

Hello,

 

I try to communicate on UART3 (pin 11/13) just TTL, but cannot see any data on the lines.

After first attempt i added overlays=uart3 to /boot/armbianEnv.txt  and rebooted the system.

oot@orangepioneplus:~# cat /boot/armbianEnv.txt
verbosity=1
bootlogo=false
console=both
disp_mode=1920x1080p60
overlay_prefix=sun50i-h6
rootdev=UUID=d7bd3629-b17f-4c85-9031-909157a0ce7e
rootfstype=ext4
overlays=uart3
usbstoragequirks=0x2537:0x1066:u,0x2537:0x1068:u

Then i also executed update-initramfs -u and rebooted the board.

 

None of these are helped :(

 

I wonder what i am doing wrong?

 

I see the following in the logs:

root@orangepioneplus:~# dmesg | egrep --color 'serial|ttyS'
[    1.944312] printk: console [ttyS0] disabled
[    1.944394] 5000000.serial: ttyS0 at MMIO 0x5000000 (irq = 31, base_baud = 1500000) is a 16550A
[    1.944599] printk: console [ttyS0] enabled
[    1.945269] sun50i-h6-pinctrl 300b000.pinctrl: pin-119 (5000c00.serial) status -517
[    1.945284] dw-apb-uart 5000c00.serial: Error applying setting, reverse things back
[    1.971491] sun50i-h6-pinctrl 300b000.pinctrl: pin-119 (5000c00.serial) status -517
[    1.971505] dw-apb-uart 5000c00.serial: Error applying setting, reverse things back
[    1.973846] sun50i-h6-pinctrl 300b000.pinctrl: pin-119 (5000c00.serial) status -517
[    1.973860] dw-apb-uart 5000c00.serial: Error applying setting, reverse things back
[    1.975764] sun50i-h6-pinctrl 300b000.pinctrl: pin-119 (5000c00.serial) status -517
[    1.975778] dw-apb-uart 5000c00.serial: Error applying setting, reverse things back
[    2.376127] sun50i-h6-pinctrl 300b000.pinctrl: pin-119 (5000c00.serial) status -517
[    2.376141] dw-apb-uart 5000c00.serial: Error applying setting, reverse things back
[    2.401927] 5000c00.serial: ttyS3 at MMIO 0x5000c00 (irq = 32, base_baud = 1500000) is a 16550A
[    5.035583] systemd[1]: Created slice system-serial\x2dgetty.slice.

I think it is looks okey.

Also i can connect to UART0.

During testing i used the same setting on minicom as UART0
 

    +-----------------------------------------------------------------------+
    | A -    Serial Device      : /dev/ttyS3                                |
    | B - Lockfile Location     : /var/lock                                 |
    | C -   Callin Program      :                                           |
    | D -  Callout Program      :                                           |
    | E -    Bps/Par/Bits       : 9600 8N1                                  |
    | F - Hardware Flow Control : No                                        |
    | G - Software Flow Control : No                                        |
    |                                                                       |
    |    Change which setting?                                              |
    +-----------------------------------------------------------------------+

 

Also just done a same test with a USB-serial adapter which is worked so i can rule out at least problem with my testing mythology.

 

Thank you!

 

Link to post
Share on other sites
Donate and support the project!

50 minutes ago, ebalcsk said:

I try to communicate on UART3

Can you check DT if pinctrl-0 is present in UART3 node ?

 

You can verify using this :

ll /proc/device-tree/soc/serial@5000c00

(In my old 5.9 build, I see that they are missing and only UART0 has its pinctl-0 handle.)

 

If missing, you can decompile DTB into DTS, edit DTS to add "pinctrl-0 = <phandle>;" where phandle can be found in "uart3-pins" node ...

Link to post
Share on other sites

it looks like exist:

root@orangepioneplus:~# ll /proc/device-tree/soc/serial@5000c00
total 0
-r--r--r-- 1 root root  8 Feb 10 21:50 clocks
-r--r--r-- 1 root root 17 Feb 10 21:50 compatible
-r--r--r-- 1 root root 12 Feb 10 21:50 interrupts
-r--r--r-- 1 root root  7 Feb 10 21:50 name
-r--r--r-- 1 root root  4 Feb 10 21:50 phandle
-r--r--r-- 1 root root  4 Feb 10 21:50 pinctrl-0
-r--r--r-- 1 root root  8 Feb 10 21:50 pinctrl-names
-r--r--r-- 1 root root  8 Feb 10 21:50 reg
-r--r--r-- 1 root root  4 Feb 10 21:50 reg-io-width
-r--r--r-- 1 root root  4 Feb 10 21:50 reg-shift
-r--r--r-- 1 root root  8 Feb 10 21:50 resets
-r--r--r-- 1 root root  5 Feb 10 21:50 status
root@orangepioneplus:~#

 

Link to post
Share on other sites
root@orangepioneplus:~# dtc -@ -I dtb -O dts -o /root/sun50i-h6-orangepi-one-plus.dts-5.10.12 /boot/dtb/allwinner/sun50i-h6-orangepi-one-plus.dtb
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@480000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@720000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@816000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@888000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@1080000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@1320000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@1488000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@1608000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@1704000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (unit_address_vs_reg): /cpu-opp-table/opp@1800000000: node has a unit name, but no reg property
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (graph_child_address): /soc/tcon-top@6510000/ports/port@0: graph node has single child node 'endpoint@0', #address-cells/#size-cells are not necessary
/root/sun50i-h6-orangepi-one-plus.dts-5.10.12: Warning (graph_child_address): /soc/tcon-top@6510000/ports/port@4: graph node has single child node 'endpoint@0', #address-cells/#size-cells are not necessary
root@orangepioneplus:~#

 

sun50i-h6-orangepi-one-plus.dts-5.10.12

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...