Looking for more recent build for x96 mini


Recommended Posts

@robertoenr 

 

I have installed Armbian 20.10 Focal 5.9.7 in my OTT TV BOX X96 mini 1 + 8GB and it works well, only the wifi that does not work, I want to know if there is a more advanced kernel to install it on these equipment.

 

Equipment information:

- Amlogic S905W chipset

* Quad Core 1.2GHz 64bit Cortex-A53 Mali-450

* 1 GiB of DDR3 memory

- 8 GiB of eMMC flash

- 10/100Mbit Ethernet

- HDMI output up to 4K30P

- Model: X96 mini.

 

I would like to install one such as: Armbian 21.xx Focal 5.10.x, if some one knows please let me know.

Link to post
Share on other sites
Donate and support the project!

@robertoenr

I have Armbian 20.10 Focal 5.9.7 installed and I updated it to Ubuntu OS: Ubuntu 20.04.2 LTS (server mode) aarch64 || Host: Oranth Tanix TX3 Mini || Kernel: 5.9.7-arm-64

 

 

my device is: X96 mini

Amlogic S905W chipset

Quad Core 1.2GHz 64bit Cortex-A53 Mali-450

1 or 2 GiB of DDR3 memory

8 or 16 GiB of eMMC flash

10/100Mbit Ethernet

HDMI output up to 4K30P

 

I would like to install one such as: Armbian 21.xx Focal 5.10.x, if some one knows please let me know.

Link to post
Share on other sites
23 minutes ago, Joel Mercedes said:

@robertoenr

I have Armbian 20.10 Focal 5.9.7 installed and I updated it to Ubuntu OS: Ubuntu 20.04.2 LTS (server mode) aarch64 || Host: Oranth Tanix TX3 Mini || Kernel: 5.9.7-arm-64

 

 

my device is: X96 mini

Amlogic S905W chipset

Quad Core 1.2GHz 64bit Cortex-A53 Mali-450

1 or 2 GiB of DDR3 memory

8 or 16 GiB of eMMC flash

10/100Mbit Ethernet

HDMI output up to 4K30P

 

I would like to install one such as: Armbian 21.xx Focal 5.10.x, if some one knows please let me know.

 

Hi @Joel Mercedes the last image you can install for Amlogic devices is the 20.10 with kernel 5.9.0 created by @balbes150

WIFI generally does not work on this cheap devices. You must use ethernet or a 1$ wifi-usb dongle.

 

Anyway:

What image did you install to get the kernel 5.9.7? Or did you update the kernel over 5.9.0?

What DTB are you using?

Link to post
Share on other sites