Jump to content
  • 0

NanoPi M4v2 - Monitor turns off (no signal text) at startup booting after Starting kernel ... text



I have an FriendlyElec M4v2 board without eMMC card. (so i only use SD card)

I tried this image: Armbian_21.02.1_Nanopim4v2_focal_current_5.10.12_desktop.img

I Wrote to SD with Balena Etcher.


After the new installation I turning on my board, I see my two attached .jpg file contents on the screen and after my screen flashes and

immediately turns off my monitor (with no signal text on the screen) and if then I can only see Armbian again if I turn my monitor off and after on.

So the Armbian is booting in the background, just need an HDMI channel refresh with a monitor physical off and after on.


Then I installed all updates ('apt update' after 'apt upgrade') but it didn't help anything,,,

,,, in fact, it got worse because the system became unstable.
The OS screen did not return to the monitor four times.
I tried 6 times turns off the monitor and turn back on.

I tried with Buster image,,, same problem.
I tried the FriendElec images (FriendlyDesktop and Android10), all work well (so no hardware problem), only the two Armbian images do not (Focal and Buster).


Please write me how I can solve it so that after I turn on my board the next image should be on the Armbian login screen without monitor turn off-on.


I made a short video, maybe it can help: ' Before updates, Newly installed system, second power on.avi '

https://www.dropbox.com/s/8m72sm1a2t5guk5/Before updates%2C Newly installed system%2C second power on.avi?dl=1


left photo = Newly installed system Before updates.jpg

right photo = Newly installed system After all updates.jpg




Edited by greglly
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

Donate your old hardware to community. Start a giveaway Raffle!

  • 0
8 hours ago, greglly said:

then I can only see Armbian again if I turn my monitor off and after on

Known issue with hdmi enabled in u-boot and rk3399.


8 hours ago, greglly said:

in fact, it got worse because the system became unstable.

NanoPi M4V2 is long known to be unstable in current and dev branches - you can search the forum.


Fortunately there is hope ;-) Try the image referred in the following message and report your results.

It contains both stability fix and the "lying around patch" to disable hdmi in u-boot.


Link to comment
Share on other sites

  • 0

Dear piter75


I’m not a beginner, but I’m not even at a completely advanced level.
I don’t see crystal clear with the help links you sent above.
Please write here more simply in a few steps how to solve my problem.
I’ll do everything, just the links above are too complicated because you don’t know exactly where to find the file to repair.


Thank you very much for your work and help !

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines