Jump to content

Partitions for nand-sata-install

Go to solution Solved by Werner,

Recommended Posts



I have Armbian running on a Lime2. It runs from the microSD.

The board has eMMC and I have also connected a SATA SSD through USB

because I would like to move the system to the SSD.

I have tried doing so through the nand-sata-install.sh script but it always shows the following message:

There are no available partitions. Please create them.

I get that message no matter if I choose to have the boot partition on eMMC or on microSD.

And I don't know much about partitions.


What partitions should I create?

Where should I create them?

How should I create them?


Thank you!


Link to comment
Share on other sites

  • Solution

Try to check fdisk -l

In theory you should get two results: your sdcard and your eMMC.

Once you got the block device  of your eMMC open it with a partition tool like cfdisk and try to create a partition on it.


Not sure whats wrong though because the script should take care for it...in theory.

Link to comment
Share on other sites

Thank you @Werner!


I followed your instructions. I found the eMMC device through fdisk -l and then I run cfdisk on it, so now it has a linux partition.


However, nothing has changed, I keep receiving the same message when I choose to move things to USB/SATA, I keep getting:

There are no avaliable partitions. Please create them.


Link to comment
Share on other sites

Seems like a bug, this is an old post so maybe if anyone has the same issue, do what I did:  I got same error so I created two partitions for boot and root. Of course /boot was not mounted and used at all so it ended up as part of root and my board would not boot. I fixed this by mounting it and copying the files myself.

Link to comment
Share on other sites

If install scripts such as" nand-sata-install" are not working, with the error message about partition size, cd into /mnt and delete the unwanted script remnants with the command sudo rm -r -f (unwanted file)
**example:** "sudo rm -r -f nand-sata-install.ctNNK4"

Each time that you remove the install scripts from /mnt , you also have to unmount /dev/md0 (sudo umount /dev/md0) otherwise it will give you an error saying nand-sata-install.xxxxxx is in use and can't be deleted while attempting to delete the next. When you are done, make sure there is nothing other than md0 (if you're running on an arrray) in /mnt and then unmount /dev/md0 for the last time before running the nand-sata-install script.

the script will now work.


Also, I'm guessing you might have to do the same with /dev/sdx if you are using an mdadm array.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines