Error while install linux-image-current-meson64


zaqwsx12
 Share

0

Recommended Posts

# apt-get install linux-image-current-meson64
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  linux-image-current-meson64
0 upgraded, 1 newly installed, 0 to remove and 3 not upgraded.
Need to get 0 B/42.5 MB of archives.
After this operation, 214 MB of additional disk space will be used.
Selecting previously unselected package linux-image-current-meson64.
(Reading database ... 85331 files and directories currently installed.)
Preparing to unpack .../linux-image-current-meson64_21.02.3_arm64.deb ...
Unpacking linux-image-current-meson64 (21.02.3) ...
Setting up linux-image-current-meson64 (21.02.3) ...
 * dkms: running auto installation service for kernel 5.10.21-meson64                                                                [ OK ]
update-initramfs: Generating /boot/initrd.img-5.10.21-meson64
update-initramfs: Converting to u-boot format
dpkg: error processing package linux-image-current-meson64 (--configure):
 installed linux-image-current-meson64 package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 linux-image-current-meson64
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

Link to post
Share on other sites

Donate and support the project!

where did you get the .deb for the linux-image (5.10.21-meson64)?

 

Why didnt you used armbian-config (System -> Other -> Switch to other Kernel) to change the kernel/image?

 

When you did selfcompile the image via armbian-build-system....did you try to update the packages like u-boot, firmware and so on before the linux-image?

Link to post
Share on other sites

You can't install armbian kernels on the balbes150 TV box builds.  The file layouts are not compatible.  TV boxes are not supported, there are not upgrade paths for the kernels. (Maybe someday, but not today).  Also there are no builds that support the amlogic s9xx cpus after 2020-10-14 as the developer who was working on them dropped support for them at that time.

Link to post
Share on other sites

 Share

0