Zram not enabled/No Swap


SenorSmartyPants
 Share

1 1

Recommended Posts

I'm finally realizing that I have no swap and zram is not enabled. I just checked /etc/default/armbian-zram-config and ENABLED=false

 

I'm running Armbian buster with Linux 5.4.49-rockchip64 on a RockPi4A. 

 

Is zram turned off by default?

 

Did I screw up/miss a step when setting up my system (quite a while back)?

 

My system boots from an SD card. I have no SSD in the system just SATA and USB HDD.

 

I've been having system hangs when memory runs out (which has not been frequent but is very annoying)

 

I run most things in Docker, so if I needed to rebuild from scratch it's not the worst thing in the world. Especially if there is a way to enable hardware video accelleration in a headless setup.

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

22 minutes ago, SenorSmartyPants said:

Did I screw up/miss a step when setting up my system (quite a while back)?


Probably you missed this 

and this https://www.armbian.com/bugs Logs logs logs. Then someone can have some clue what is the issue.

 

24 minutes ago, SenorSmartyPants said:

Is zram turned off by default?


Yes, since many years. You must have started with some preview build where things were not finished or break somehow ...

Link to post
Share on other sites

5 minutes ago, Igor said:

Yes, since many years. You must have started with some preview build where things were not finished or break somehow ...

 

I thought I remembered that zram was supposed to be off. But should htop and free -m report no swap? Just trying to figure out if that's how it should look, or if that's definitely messed up.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

1 1