Teamviewer


niccodemi
 Share

3 3

Recommended Posts

Hi,

 

I've been using Armbian with Banana Pi M2 for a while and I am very satisfied with performance. Recently I noticed that Teamviewer has been developed for ARM systems, officially only for Raspbian but it seems few people had success running it on Orange Pi too. 

 

I followed installation instructions and succeeded however once I connect to it I see only black screen.

 

Did anyone else manage to get it working?

 

Below is link to original thread:

 

https://www.raspberrypi.org/forums/viewtopic.php?f=63&t=144608

 

 

Link to post
Share on other sites

Donate and support the project!

Install TeamViewer

wget http://download.teamviewer.com/download/linux/version_11x/teamviewer-host_armhf.deb
dpkg -i teamviewer-host_armhf.deb

Install dependencies:

apt install -f

Get ID:

cat /etc/teamviewer/global.conf | grep ClientID

Finally, try logging in from another desktop using the TeamViewer desktop client
Add a permanent password:

teamviewer passwd my_password
Link to post
Share on other sites

I stumbled upon another solution for me: LogMeIn Hamachi. It creates a VPN connection and I can remotely access my OrangePi using IP. The hamachi client for armhf works very well, I used a tutorial from raspberry forums and found useful tips in a thread in orangepi.org forums. So I can remotely wake my PC at home with my OrangePi (wake on lan) and then use Teamviewer Android client with my PC (Teamviewer ist most useful for me).

Link to post
Share on other sites

On 8/8/2016 at 5:55 PM, shahidali55 said:

Install TeamViewer


wget http://download.teamviewer.com/download/linux/version_11x/teamviewer-host_armhf.deb
dpkg -i teamviewer-host_armhf.deb

Install dependencies:


apt install -f

Get ID:


cat /etc/teamviewer/global.conf | grep ClientID

Finally, try logging in from another desktop using the TeamViewer desktop client
Add a permanent password:


teamviewer passwd my_password

 

 

Hello :)

 

What i put in " ClientID " the ID from the armbian teamvieweer or the ID of my laptop xubuntu ( where i want to use to connect to my armbian ) ?

 

Link to post
Share on other sites

I'm on Armbian ( debian 9 Stretch dev ) in Armbian ( Ubuntu Bionic 18.04.1 ) Teamviewer seems to doesn't work. On debian Teamviewer seems to works but i can't see my armbian under teamviewer where as all seems to be good, so i think i've missed something like your " ClientID ".

Link to post
Share on other sites

ok i understood :)   cat /etc/teamviewer/global.conf | grep ClientID   = to see what is the clientID on Armbian (debian 9 for me) but i see already my ID because Teamviewer starts normally and it shows the ID to connect, but when i connect from my laptop to my armbian nothing happens...

Link to post
Share on other sites

déc. 09 20:37:04 gon systemd[1]: Starting TeamViewer remote control daemon...
déc. 09 20:37:04 gon systemd[1]: teamviewerd.service: PID file /var/run/teamviewerd.pid not readable (yet?) after start: No such file or directory
déc. 09 20:37:04 gon systemd[1]: Started TeamViewer remote control daemon.

Link to post
Share on other sites

Well teamviewer is active in Armbian but impossible to connect from another devices... ( teamviewer-host ) <- ( for armbian ) and i try to connect from ( teamviewer-amd64 ) <- ( my laptop xubuntu ) nothing happens just written " connecting " but the armbian desktop doesn't appears..... Ouiiiinnnnnnnnnnnnnnnn :'( :'( :'(   i'm going to try another remote control...

Link to post
Share on other sites

Worked on the last Ubuntu Bionic but the wired is still broken where as on debian wired works perfectly, but x2go don't work actually on ARMBIAN 5.75 stable Debian GNU/Linux 9 (stretch) 4.19.20-sunxi :( i'm going to test again with teamviewer to see if it's work

Link to post
Share on other sites

Hi Nelson. I've tried the DWService. The file and console access works good, but not the Screen one.

Which Armbian version are were you using?

 

I am really disappointed since no remote desktop over WAN has worked for me (although on LAN works perfect). I tried anydesk, teamviewer, RealVNC with no luck. A real bummer for my little projectes.

 

Any ideas on how to solve that?

Thanks!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

3 3