XU4 loses network connections over time


Recommended Posts

Armbianmonitor:

Howdy, I'm running Armbian_21.05.1_Odroidxu4_focal_current_5.4.116.img on my XU4 for security cameras. It averages about 60 Mbps 24/7. After a couple days usually one adapter disappears (from ip a and nmtui) and sometimes both (I have a USB 1 Gbps adapter too). I'm not seeing anything in the logs to indicate an error. I monitor this system with Zabbix and I see no unusual activity before this happens. Is there a way to get diagnostics for this event?  

Link to post
Share on other sites
Donate and support the project!

Yeah, looks like https://github.com/aler9/rtsp-simple-server might have some issues, but that shouldn't kill the NICs. Memory averages around 1.3G free which is excellent for 5 4K cameras. Nothing obvious sticks out. I have a SSD and 1G Ethernet dongle connected to USB 3. I believe I have a 4A power supply. I have another XU4 with 2 SSDs on USB 3 that works fine, but has less network activity (like 20 Mbps). The weird thing is the heartbeat is till cranking and I have to power cycle to get NICs back.

 

If it makes any difference I have 5 to 7 ffmpeg processes running all the time. Processes average around 150. I didn't tweak any kernel parameters. Anyways, I tried swapping power supplies with another board just for the heck of it.

 

chart1.png

chart2.png

chart3.png

Link to post
Share on other sites

6A PSU https://www.hardkernel.com/shop/5v-6a-power-supply-unit/

 

When you connect an external 2.5inch HDD/SSD to XU4 or using the CloudShell,
the bundle 5V/4A power supply is not enough to supply stable power.
We strongly recommend to use this 5V/6A PSU to improve the system stability.

 

So maybe my PSU theory is correct. Would also explain where there's really nothing in the logs.

 

Just ordered this guy. No use troubleshooting a software problem until I rule out hardware :) https://www.amazon.com/gp/product/B07H9X8FHM

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...