RockPro64 only booting legacy kernel


Leco
 Share

1 1

Recommended Posts

Hello everyone,

 

First of all, thank you all for making ARM accessible!

 

I have a RockPro64 that only boot legacy kernels... I couldn't find anything specific about it online.

Is this something to do with the SPI chip? Do I have to update it with the procedure listed here? https://github.com/ayufan-rock64/linux-build/blob/master/recipes/flash-spi.md

Any tip would be really welcome, I tried most of the ROCKPRO64 images and nothing... only kernel 4.x boot, SD or emmc, no difference.

 

Bellow is one of the error messages I get... the screen flashes different colors and the system halts.

Different images, different behaviors... usually it just flash colors.

(Warning... Bad CRC) is this CRC about the SPI firmware?  It's not the emmc or SD. I tried different ones and it just doesn't work for mainline kernels.

 

No HDMI output and I won't see an new IP on my network.

I tried it without the HDMI cable too.. nothing.

 

Thank you for any assistance!

 

image.thumb.png.3ab77ff7eaa0774aa9acc2902ceb3b71.png

 

 

 

Board: Rock64
Link to post
Share on other sites

Donate and support the project!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

1 1