I am starting out with a BananPi Pro - I'm a newbie to Linux troubleshooting - Why are some DT overlays not loading on boot?


Myron
 Share

2 2

Recommended Posts

Hello kind folk.  Hoping someone can help.  What's listed below is what gone wrong.

Armbian monitor diagnostics dump: http://ix.io/3yOY

 

All I've done is install Armbian, did the 'apt update && apt upgrade' and enabled options to see how will it will work.   I'm not sure if I have done something wrong for several DT overlays not to load.

 

I can see it states that (what is an ftd?) base ftds are missing a node and need recompiling.  How do I do that?

(The analog codec does load. It's the only one that does.)

 

U-Boot SPL 2020.10-armbian (Aug 08 2021 - 14:48:33 +0200)
DRAM: 1024 MiB
CPU: 912000000Hz, AXI/AHB/APB: 3/2/2
Trying to boot from MMC1


U-Boot 2020.10-armbian (Aug 08 2021 - 14:48:33 +0200) Allwinner Technology

CPU:   Allwinner A20 (SUN7I)
Model: LeMaker Banana Pro
I2C:   ready
DRAM:  1 GiB
MMC:   mmc@1c0f000: 0, mmc@1c12000: 1
Loading Environment from FAT... Unable to use mmc 0:1... Setting up a 720x576i composite-pal console (overscan 32x20)
In:    serial
Out:   vga
Err:   vga
Net:   eth0: ethernet@1c50000
230454 bytes read in 17 ms (12.9 MiB/s)
starting USB...
Bus usb@1c14000: USB EHCI 1.00
Bus usb@1c14400: USB OHCI 1.0
Bus usb@1c1c000: USB EHCI 1.00
Bus usb@1c1c400: USB OHCI 1.0
scanning bus usb@1c14000 for devices... 1 USB Device(s) found
scanning bus usb@1c14400 for devices... 1 USB Device(s) found
scanning bus usb@1c1c000 for devices... 1 USB Device(s) found
scanning bus usb@1c1c400 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Autoboot in 1 seconds
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
3964 bytes read in 4 ms (967.8 KiB/s)
## Executing script at 43100000
U-boot loaded from SD
Boot script loaded from mmc
281 bytes read in 4 ms (68.4 KiB/s)
11582960 bytes read in 639 ms (17.3 MiB/s)
7995296 bytes read in 441 ms (17.3 MiB/s)
Found mainline kernel configuration
40795 bytes read in 8 ms (4.9 MiB/s)
267 bytes read in 10 ms (25.4 KiB/s)
Applying kernel provided DT overlay sun7i-a20-analog-codec.dtbo
386 bytes read in 10 ms (37.1 KiB/s)
Applying kernel provided DT overlay sun7i-a20-can.dtbo
failed on fdt_overlay_apply(): FDT_ERR_NOTFOUND
500 bytes read in 9 ms (53.7 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c1.dtbo
failed on fdt_overlay_apply(): FDT_ERR_BADMAGIC
base fdt does did not have a /__symbols__ node
make sure you've compiled with -@
500 bytes read in 10 ms (48.8 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c2.dtbo
failed on fdt_overlay_apply(): FDT_ERR_BADMAGIC
base fdt does did not have a /__symbols__ node
make sure you've compiled with -@
500 bytes read in 9 ms (53.7 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c3.dtbo
failed on fdt_overlay_apply(): FDT_ERR_BADMAGIC
base fdt does did not have a /__symbols__ node
make sure you've compiled with -@
766 bytes read in 10 ms (74.2 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c4.dtbo
failed on fdt_overlay_apply(): FDT_ERR_BADMAGIC
base fdt does did not have a /__symbols__ node
make sure you've compiled with -@
778 bytes read in 10 ms (75.2 KiB/s)
Applying kernel provided DT overlay sun7i-a20-pps-gpio.dtbo
failed on fdt_overlay_apply(): FDT_ERR_BADMAGIC
base fdt does did not have a /__symbols__ node
make sure you've compiled with -@
443 bytes read in 10 ms (43 KiB/s)
Applying kernel provided DT overlay sun7i-a20-pwm.dtbo
failed on fdt_overlay_apply(): FDT_ERR_BADMAGIC
base fdt does did not have a /__symbols__ node
make sure you've compiled with -@
1069 bytes read in 11 ms (94.7 KiB/s)
Applying kernel provided DT overlay sun7i-a20-spi-spidev.dtbo
failed on fdt_overlay_apply(): FDT_ERR_BADMAGIC
base fdt does did not have a /__symbols__ node
make sure you've compiled with -@
777 bytes read in 11 ms (68.4 KiB/s)
Applying kernel provided DT overlay sun7i-a20-w1-gpio.dtbo
failed on fdt_overlay_apply(): FDT_ERR_BADMAGIC
base fdt does did not have a /__symbols__ node
make sure you've compiled with -@
Error applying DT overlays, restoring original DT
40795 bytes read in 8 ms (4.9 MiB/s)
## Loading init Ramdisk from Legacy Image at 43300000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    11582896 Bytes = 11 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 43000000
   Booting using the fdt blob at 0x43000000
EHCI failed to shut down host controller.
   Loading Ramdisk to 494f4000, end 49fffdb0 ... OK
   Loading Device Tree to 494e7000, end 494f3f5a ... OK

Starting kernel ...


Armbian 21.08.2 Focal ttyS0

medusa login:

 

Link to post
Share on other sites

Donate and support the project!

Hi,

An "fdt" is a flattened device tree (e.g. sun7i-a20-bananapi.dtb) which will be in your /boot/dtb directory.

The "-@" option is used when running dtc (the devicetree compiler) to create the fdt. It tells the compiler to include symbols details in the .dtb.  These are needed so overlays can be applied.

But you'll need the source files and compiler to create the .dtb and this shouldn't be necessary.

I'm wondering if the first overlay (analogue-codec) is causing the problem.  Can you try deleting it from your "overlays=" line in armbianEnv.txt to see what happens ?

The fact that the "can.dtbo" overlay is not found might cause a problem.  Does it exist ? Can you try deleting it from the "overlays=" line and see what happens ?

Hopefully someone with more knowledge will chip in here and help.

Cheers,
Steven
 

Link to post
Share on other sites

Thanks. will look at that when I can. My legacy Rasberry v1 Rasberry Pi has died which I was using for a specific set of tasks and I've had to put the BananaPro in it's place as the replacement.

 

At the moment this is the content of armbianEnv.txt:

verbosity=1
bootlogo=false
console=both
disp_mode=1920x1080p60
overlay_prefix=sun7i-a20
rootdev=UUID=dffd2ee5-5480-480b-9853-7884f8ba5e47
rootfstype=ext4
overlays=analog-codec
usbstoragequirks=0x2537:0x1066:u,0x2537:0x1068:u

I removed the overlays that where not loading.  Not using that at the moment, but I would have expected the drivers to at least load.

 

I'm assuming that the analog-codec is to do with the microphone that's build in to the BananaPro and I may be actively [nor for spying! :-) ] using that some time in the future.

Link to post
Share on other sites

When I saw your original log listing all the failed overlay loads I assumed your "overlay=" line would be a long list containing all of them.  But it's not and your single entry there looks fine to me.

 

Can you try booting with no overlays and if it works then add entries to your "ovelays=" line one by one ?

 

Link to post
Share on other sites

It does seem that there are specific DTs that do not load, but I did notice one particular thing and this can only be seen observing output from the serial debug port, if ANY dt overlays fail then I get . . .

 

   Error applying DT overlays, restoring original DT

 

If all the device tree overlays succeed then I get . . .

 

   Applying kernel provided DT fixup script (sun7i-a20-fixup.scr)

 

Is this an all or nothing scenario, where if one overlay does not initialise correctly then no overlays get applied?

 

When it comes to device trees I am an absolute noob.

armbian-monitor details of my BananaPro as it is when I post this reply: http://ix.io/3zxW (As well as all the others that are still in there)

 

Reboots while I had the USB to TTL RS232 bridge connected:

▒
U-Boot SPL 2021.07-armbian (Sep 13 2021 - 23:19:26 +0200)
DRAM: 1024 MiB
CPU: 912000000Hz, AXI/AHB/APB: 3/2/2
Trying to boot from MMC1


U-Boot 2021.07-armbian (Sep 13 2021 - 23:19:26 +0200) Allwinner Technology

CPU:   Allwinner A20 (SUN7I)
Model: LeMaker Banana Pro
I2C:   ready
DRAM:  1 GiB
MMC:   mmc@1c0f000: 0, mmc@1c12000: 2
Loading Environment from FAT... Unable to use mmc 0:1... Setting up a 720x576i composite-pal console (overscan 32x20)
In:    serial
Out:   vidconsole
Err:   vidconsole
Net:   eth0: ethernet@1c50000
230454 bytes read in 17 ms (12.9 MiB/s)
starting USB...
Bus usb@1c14000: USB EHCI 1.00
Bus usb@1c14400: USB OHCI 1.0
Bus usb@1c1c000: USB EHCI 1.00
Bus usb@1c1c400: USB OHCI 1.0
scanning bus usb@1c14000 for devices... 1 USB Device(s) found
scanning bus usb@1c14400 for devices... 1 USB Device(s) found
scanning bus usb@1c1c000 for devices... 1 USB Device(s) found
scanning bus usb@1c1c400 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Autoboot in 1 seconds, press <Space> to stop
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
3964 bytes read in 4 ms (967.8 KiB/s)
## Executing script at 43100000
U-boot loaded from SD
Boot script loaded from mmc
230 bytes read in 4 ms (55.7 KiB/s)
11588626 bytes read in 639 ms (17.3 MiB/s)
7995288 bytes read in 442 ms (17.3 MiB/s)
Found mainline kernel configuration
41126 bytes read in 10 ms (3.9 MiB/s)
267 bytes read in 11 ms (23.4 KiB/s)
Applying kernel provided DT overlay sun7i-a20-analog-codec.dtbo
500 bytes read in 10 ms (48.8 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c1.dtbo
5532 bytes read in 11 ms (490.2 KiB/s)
Applying kernel provided DT fixup script (sun7i-a20-fixup.scr)
## Executing script at 45000000
Kernel image @ 0x42000000 [ 0x000000 - 0x79ff98 ]
## Loading init Ramdisk from Legacy Image at 43400000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    11588562 Bytes = 11.1 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 43000000
   Booting using the fdt blob at 0x43000000
EHCI failed to shut down host controller.
   Loading Ramdisk to 494f2000, end 49fff3d2 ... OK
   Loading Device Tree to 4947f000, end 494f1fff ... OK

Starting kernel ...


Armbian 21.08.2 Focal ttyS0

loki login: [  177.621676] reboot: Restarting system

U-Boot SPL 2021.07-armbian (Sep 13 2021 - 23:19:26 +0200)
DRAM: 1024 MiB
CPU: 912000000Hz, AXI/AHB/APB: 3/2/2
Trying to boot from MMC1


U-Boot 2021.07-armbian (Sep 13 2021 - 23:19:26 +0200) Allwinner Technology

CPU:   Allwinner A20 (SUN7I)
Model: LeMaker Banana Pro
I2C:   ready
DRAM:  1 GiB
MMC:   mmc@1c0f000: 0, mmc@1c12000: 2
Loading Environment from FAT... Unable to use mmc 0:1... Setting up a 720x576i composite-pal console (overscan 32x20)
In:    serial
Out:   vidconsole
Err:   vidconsole
Net:   eth0: ethernet@1c50000
230454 bytes read in 17 ms (12.9 MiB/s)
starting USB...
Bus usb@1c14000: USB EHCI 1.00
Bus usb@1c14400: USB OHCI 1.0
Bus usb@1c1c000: USB EHCI 1.00
Bus usb@1c1c400: USB OHCI 1.0
scanning bus usb@1c14000 for devices... 1 USB Device(s) found
scanning bus usb@1c14400 for devices... 1 USB Device(s) found
scanning bus usb@1c1c000 for devices... 1 USB Device(s) found
scanning bus usb@1c1c400 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Autoboot in 1 seconds, press <Space> to stop
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
3964 bytes read in 4 ms (967.8 KiB/s)
## Executing script at 43100000
U-boot loaded from SD
Boot script loaded from mmc
216 bytes read in 4 ms (52.7 KiB/s)
11588626 bytes read in 638 ms (17.3 MiB/s)
7995288 bytes read in 441 ms (17.3 MiB/s)
Found mainline kernel configuration
41126 bytes read in 10 ms (3.9 MiB/s)
386 bytes read in 11 ms (34.2 KiB/s)
Applying kernel provided DT overlay sun7i-a20-can.dtbo
failed on fdt_overlay_apply(): FDT_ERR_NOTFOUND
Error applying DT overlays, restoring original DT
41126 bytes read in 9 ms (4.4 MiB/s)
Kernel image @ 0x42000000 [ 0x000000 - 0x79ff98 ]
## Loading init Ramdisk from Legacy Image at 43400000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    11588562 Bytes = 11.1 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 43000000
   Booting using the fdt blob at 0x43000000
EHCI failed to shut down host controller.
   Loading Ramdisk to 494f2000, end 49fff3d2 ... OK
   Loading Device Tree to 494e4000, end 494f10a5 ... OK

Starting kernel ...


Armbian 21.08.2 Focal ttyS0

loki login: [  173.714013] reboot: Restarting system

U-Boot SPL 2021.07-armbian (Sep 13 2021 - 23:19:26 +0200)
DRAM: 1024 MiB
CPU: 912000000Hz, AXI/AHB/APB: 3/2/2
Trying to boot from MMC1


U-Boot 2021.07-armbian (Sep 13 2021 - 23:19:26 +0200) Allwinner Technology

CPU:   Allwinner A20 (SUN7I)
Model: LeMaker Banana Pro
I2C:   ready
DRAM:  1 GiB
MMC:   mmc@1c0f000: 0, mmc@1c12000: 2
Loading Environment from FAT... Unable to use mmc 0:1... Setting up a 720x576i composite-pal console (overscan 32x20)
In:    serial
Out:   vidconsole
Err:   vidconsole
Net:   eth0: ethernet@1c50000
230454 bytes read in 17 ms (12.9 MiB/s)
starting USB...
Bus usb@1c14000: USB EHCI 1.00
Bus usb@1c14400: USB OHCI 1.0
Bus usb@1c1c000: USB EHCI 1.00
Bus usb@1c1c400: USB OHCI 1.0
scanning bus usb@1c14000 for devices... 1 USB Device(s) found
scanning bus usb@1c14400 for devices... 1 USB Device(s) found
scanning bus usb@1c1c000 for devices... 1 USB Device(s) found
scanning bus usb@1c1c400 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Autoboot in 1 seconds, press <Space> to stop
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
3964 bytes read in 4 ms (967.8 KiB/s)
## Executing script at 43100000
U-boot loaded from SD
Boot script loaded from mmc
245 bytes read in 3 ms (79.1 KiB/s)
11588626 bytes read in 639 ms (17.3 MiB/s)
7995288 bytes read in 441 ms (17.3 MiB/s)
Found mainline kernel configuration
41126 bytes read in 9 ms (4.4 MiB/s)
267 bytes read in 11 ms (23.4 KiB/s)
Applying kernel provided DT overlay sun7i-a20-analog-codec.dtbo
500 bytes read in 10 ms (48.8 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c1.dtbo
500 bytes read in 10 ms (48.8 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c2.dtbo
500 bytes read in 10 ms (48.8 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c3.dtbo
766 bytes read in 11 ms (67.4 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c4.dtbo
failed on fdt_overlay_apply(): FDT_ERR_NOTFOUND
Error applying DT overlays, restoring original DT
41126 bytes read in 9 ms (4.4 MiB/s)
Kernel image @ 0x42000000 [ 0x000000 - 0x79ff98 ]
## Loading init Ramdisk from Legacy Image at 43400000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    11588562 Bytes = 11.1 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 43000000
   Booting using the fdt blob at 0x43000000
EHCI failed to shut down host controller.
   Loading Ramdisk to 494f2000, end 49fff3d2 ... OK
   Loading Device Tree to 494e4000, end 494f10a5 ... OK

Starting kernel ...


Armbian 21.08.2 Focal ttyS0

loki login: [  178.697923] reboot: Restarting system

U-Boot SPL 2021.07-armbian (Sep 13 2021 - 23:19:26 +0200)
DRAM: 1024 MiB
CPU: 912000000Hz, AXI/AHB/APB: 3/2/2
Trying to boot from MMC1


U-Boot 2021.07-armbian (Sep 13 2021 - 23:19:26 +0200) Allwinner Technology

CPU:   Allwinner A20 (SUN7I)
Model: LeMaker Banana Pro
I2C:   ready
DRAM:  1 GiB
MMC:   mmc@1c0f000: 0, mmc@1c12000: 2
Loading Environment from FAT... Unable to use mmc 0:1... Setting up a 720x576i composite-pal console (overscan 32x20)
In:    serial
Out:   vidconsole
Err:   vidconsole
Net:   eth0: ethernet@1c50000
230454 bytes read in 17 ms (12.9 MiB/s)
starting USB...
Bus usb@1c14000: USB EHCI 1.00
Bus usb@1c14400: USB OHCI 1.0
Bus usb@1c1c000: USB EHCI 1.00
Bus usb@1c1c400: USB OHCI 1.0
scanning bus usb@1c14000 for devices... 1 USB Device(s) found
scanning bus usb@1c14400 for devices... 1 USB Device(s) found
scanning bus usb@1c1c000 for devices... 1 USB Device(s) found
scanning bus usb@1c1c400 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Autoboot in 1 seconds, press <Space> to stop
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
3964 bytes read in 4 ms (967.8 KiB/s)
## Executing script at 43100000
U-boot loaded from SD
Boot script loaded from mmc
240 bytes read in 4 ms (58.6 KiB/s)
11588626 bytes read in 639 ms (17.3 MiB/s)
7995288 bytes read in 442 ms (17.3 MiB/s)
Found mainline kernel configuration
41126 bytes read in 9 ms (4.4 MiB/s)
267 bytes read in 11 ms (23.4 KiB/s)
Applying kernel provided DT overlay sun7i-a20-analog-codec.dtbo
500 bytes read in 11 ms (43.9 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c1.dtbo
500 bytes read in 11 ms (43.9 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c2.dtbo
500 bytes read in 11 ms (43.9 KiB/s)
Applying kernel provided DT overlay sun7i-a20-i2c3.dtbo
5532 bytes read in 11 ms (490.2 KiB/s)
Applying kernel provided DT fixup script (sun7i-a20-fixup.scr)
## Executing script at 45000000
Kernel image @ 0x42000000 [ 0x000000 - 0x79ff98 ]
## Loading init Ramdisk from Legacy Image at 43400000 ...
   Image Name:   uInitrd
   Image Type:   ARM Linux RAMDisk Image (gzip compressed)
   Data Size:    11588562 Bytes = 11.1 MiB
   Load Address: 00000000
   Entry Point:  00000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 43000000
   Booting using the fdt blob at 0x43000000
EHCI failed to shut down host controller.
   Loading Ramdisk to 494f2000, end 49fff3d2 ... OK
   Loading Device Tree to 4947f000, end 494f1fff ... OK

Starting kernel ...


Armbian 21.08.2 Focal ttyS0

loki login: [  109.894018] reboot: Power down
[  109.897239] ------------[ cut here ]------------
[  109.901889] WARNING: CPU: 0 PID: 1 at drivers/i2c/i2c-core.h:41 i2c_transfer+0x93/0xbc
[  109.909808] No atomic I2C transfer handler for 'i2c-1'
[  109.914946] Modules linked in: overlay l2tp_ppp l2tp_netlink l2tp_core ip6_udp_tunnel udp_tunnel pppox ppp_generic slhc nls_utf8 cifs libarc4 fscache evdev axp20x_adc lima gpu_sched sunxi_cir sun4i_gpadc_iio industrialio brcmfmac sun4i_ts brcmutil cfg80211 rfkill sunxi_cedrus(C) v4l2_mem2mem videobuf2_dma_contig videobuf2_memops videobuf2_v4l2 videobuf2_common nf_log_ipv6 ip6t_REJECT display_connector nf_reject_ipv6 uio_pdrv_genirq uio zram cpufreq_dt xt_hl ip6t_rt nf_log_ipv4 nf_log_common ipt_REJECT nf_reject_ipv4 xt_LOG xt_recent xt_limit xt_addrtype xt_tcpudp xt_conntrack nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 sch_fq_codel ip6table_filter ip6_tables iptable_filter ip_tables x_tables autofs4 pwrseq_simple sun4i_gpadc realtek
[  109.979974] CPU: 0 PID: 1 Comm: systemd-shutdow Tainted: G        WC        5.10.60-sunxi #21.08.2
[  109.988932] Hardware name: Allwinner sun7i (A20) Family
[  109.994185] [<c010ca1d>] (unwind_backtrace) from [<c010952d>] (show_stack+0x11/0x14)
[  110.001944] [<c010952d>] (show_stack) from [<c0978293>] (dump_stack+0x77/0x84)
[  110.009182] [<c0978293>] (dump_stack) from [<c011ae71>] (__warn+0xad/0xc0)
[  110.016067] [<c011ae71>] (__warn) from [<c09721bf>] (warn_slowpath_fmt+0x5f/0x7c)
[  110.023560] [<c09721bf>] (warn_slowpath_fmt) from [<c07616a7>] (i2c_transfer+0x93/0xbc)
[  110.031576] [<c07616a7>] (i2c_transfer) from [<c076170b>] (i2c_transfer_buffer_flags+0x3b/0x50)
[  110.040284] [<c076170b>] (i2c_transfer_buffer_flags) from [<c066e8ef>] (regmap_i2c_write+0x13/0x24)
[  110.049340] [<c066e8ef>] (regmap_i2c_write) from [<c066b257>] (_regmap_raw_write_impl+0x4af/0x580)
[  110.058308] [<c066b257>] (_regmap_raw_write_impl) from [<c066b369>] (_regmap_bus_raw_write+0x41/0x5c)
[  110.067535] [<c066b369>] (_regmap_bus_raw_write) from [<c066bb31>] (regmap_write+0x29/0x3c)
[  110.075896] [<c066bb31>] (regmap_write) from [<c0674f63>] (axp20x_power_off+0x23/0x30)
[  110.083826] [<c0674f63>] (axp20x_power_off) from [<c0136a39>] (__do_sys_reboot+0xf5/0x168)
[  110.092099] [<c0136a39>] (__do_sys_reboot) from [<c0100061>] (ret_fast_syscall+0x1/0x62)
[  110.100192] Exception stack(0xc1529fa8 to 0xc1529ff0)
[  110.105250] 9fa0:                   4321fedc befd1aa8 fee1dead 28121969 4321fedc 00000000
[  110.113433] 9fc0: 4321fedc befd1aa8 befd1aa4 00000058 befd1aa8 befd1aa4 fffff000 befd1aac
[  110.121613] 9fe0: 00000058 befd1a1c b6f2c545 b6eaabe6
[  110.126668] ---[ end trace 9aac65adb4b3b0e1 ]---

 

Edited by Myron
Results of test
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

2 2