Jump to content

What actions should I do to make sure bluetooth is completely disabled?

Go to solution Solved by guidol,

Recommended Posts

For some special reason, I want to make sure bluetooth is completely disabled. I have done the following:


1. Try to run hcitool & bluetoothctl. Both commands are unavailable on the system.

2. Run "systemctl status bluetooth", it says "Unit bluetooth.service could not be found." 

3. Run "service --status-all", it doesn't show bluetooth entry.


I'd assume bluetooth isn't enabled, but when I run "dmesg |grep Bluetooth", it shows:


[   13.744331] Bluetooth: Core ver 2.22
[   13.744337] Bluetooth: Starting self testing
[   13.761692] Bluetooth: ECDH test passed in 16935 usecs
[   13.764626] Bluetooth: SMP test passed in 2804 usecs
[   13.764636] Bluetooth: Finished self testing
[   13.764717] Bluetooth: HCI device and connection manager initialized
[   13.764729] Bluetooth: HCI socket layer initialized
[   13.764734] Bluetooth: L2CAP socket layer initialized
[   13.764748] Bluetooth: SCO socket layer initialized
[   13.778717] Bluetooth: Generic Bluetooth SDIO driver ver 0.1

What's the correct method to verify whether bluetooth is enabled on the system? In addition, what's the correct method to completely disable bluetooth? Any suggestions are appreciated.

Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines