A20 - Cubieboard 2


Lucas Nishimura
 Share

1 1

Recommended Posts

Hello,

   I Just installed armbian in my cubieboard and dmesg is showing an annoying message:

[   70.366543] rc rc0: IR event FIFO is full!
[   70.382773] rc rc0: IR event FIFO is full!
[   70.398930] rc rc0: IR event FIFO is full!
[   70.414907] rc rc0: IR event FIFO is full!
[   70.430890] rc rc0: IR event FIFO is full!
[   70.446706] rc rc0: IR event FIFO is full!
[   70.462248] rc rc0: IR event FIFO is full!
[   70.477582] rc rc0: IR event FIFO is full!
[   70.492758] rc rc0: IR event FIFO is full!
[   70.507816] rc rc0: IR event FIFO is full!
[   70.522829] rc rc0: IR event FIFO is full!
[   70.537806] rc rc0: IR event FIFO is full!
[   70.552683] rc rc0: IR event FIFO is full!
 
   I did a search on forum and havent find anything related to this error:
   This is some usefull info:

root@cubieboard2:~# cat /etc/armbian-release
# PLEASE DO NOT EDIT THIS FILE
BOARD=cubieboard2
BOARD_NAME="Cubieboard 2"
VERSION=5.20
LINUXFAMILY=sunxi
BRANCH=next
ARCH=arm
root@cubieboard2:~#


 
  And finally here is a link for armhwinfo.log:  http://sprunge.us/eGhd
 
 
 
 
Link to post
Share on other sites

Donate and support the project!

Hi Igor,

   Thanks for your repply, so this is what i Did:

   First checked with lsmod, loaded modules:

 

root@cubieboard2:~# lsmod
Module                  Size  Used by
sun4i_codec            11391  3
evdev                  12164  1
snd_soc_core          130295  1 sun4i_codec
snd_pcm_dmaengine       3455  1 snd_soc_core
snd_pcm                77587  2 snd_soc_core,snd_pcm_dmaengine
ir_lirc_codec           4920  0
snd_timer              19477  1 snd_pcm
lirc_dev                8310  1 ir_lirc_codec
snd                    47687  3 snd_soc_core,snd_timer,snd_pcm
soundcore                922  1 snd
sun4i_ts                3990  0
nvmem_sunxi_sid         2159  0
nvmem_core              9078  1 nvmem_sunxi_sid
sunxi_cir               3735  0
sun4i_ss               16066  0
cpufreq_dt              3432  0
thermal_sys            58884  2 cpufreq_dt,sun4i_ts
uio_pdrv_genirq         3164  0
uio                     8000  1 uio_pdrv_genirq
bonding               105270  0
root@cubieboard2:~#

Added the modules to blacklist:

 
 
root@cubieboard2:~# cat /etc/modprobe.d/blacklist.conf  | grep ir
# most apps now use garmin usb driver directly (Ubuntu: #114565)
blacklist ir_lirc_codec
blacklist lirc_dev
root@cubieboard2:~#
 
Updated initramfs:
root@cubieboard2:~# update-initramfs -u
update-initramfs: Generating /boot/initrd.img-4.7.3-sunxi
root@cubieboard2:~#

Rebooted....

But still lsmod show me those modules:

root@cubieboard2:~# lsmod
Module                  Size  Used by
sun4i_codec            11391  3
evdev                  12164  1
snd_soc_core          130295  1 sun4i_codec
snd_pcm_dmaengine       3455  1 snd_soc_core
snd_pcm                77587  2 snd_soc_core,snd_pcm_dmaengine
ir_lirc_codec           4920  0
snd_timer              19477  1 snd_pcm
lirc_dev                8310  1 ir_lirc_codec
snd                    47687  3 snd_soc_core,snd_timer,snd_pcm
soundcore                922  1 snd
sun4i_ts                3990  0
nvmem_sunxi_sid         2159  0
nvmem_core              9078  1 nvmem_sunxi_sid
sunxi_cir               3735  0
sun4i_ss               16066  0
cpufreq_dt              3432  0
thermal_sys            58884  2 cpufreq_dt,sun4i_ts
uio_pdrv_genirq         3164  0
uio                     8000  1 uio_pdrv_genirq
bonding               105270  0

So for now, i just unloaded them manually, if it works i will try to find out a permanent sollution, so for now thanks :) 

 
root@cubieboard2:~# rmmod ir_lirc_codec
root@cubieboard2:~# rmmod lirc_dev
[  242.258275] IR MCE Keyboard/mouse protocol handler initialized
[  242.297565] IR XMP protocol handler initialized
[  249.871891] lirc_dev: module unloaded
 
 
Link to post
Share on other sites

I've followed this post to remove that messages, too - and after blacklisting the 4 modules Lucas recommended in the last reply I realized that the power button has stopped working!

 

In order to keep the power button working I had to remove the evdev mode from the blacklist. The button started working again and the FIFO error messages are still not showing up.

 

Not sure about possible other consequences of this :( , but for now this is enough for me :)

 

Thanks!

Link to post
Share on other sites

This bug is still in debian version used in armbian 5.38.

 

cat /etc/armbian-release
# PLEASE DO NOT EDIT THIS FILE
BOARD=bananapi
BOARD_NAME="Banana Pi"
BOARDFAMILY=sun7i
VERSION=5.38
LINUXFAMILY=sunxi
BRANCH=next
ARCH=arm
IMAGE_TYPE=stable
BOARD_TYPE=conf
INITRD_ARCH=arm
KERNEL_IMAGE_TYPE=zImage
 

Tentative to solve it, only by creating the file bellow and reboot.

 

cat /etc/modprobe.d/blacklist.conf
blacklist ir_lirc_codec
blacklist lirc_dev
blacklist sunxi-cir
 

Just one hour up and no more FIFO is full message.

 

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

1 1