Jump to content

samba not working at all


thegaem
 Share

Recommended Posts

I see a lot of tutorials online and they all have seems to have different ways of going about making a share and it seems most of them are logged into a user as opposed to root. I'm logged in to root through ssh so that might the the cause of many of my issues I believe. I did a simple apt install samba and it seems to be running fine. I see other tutorials recommending you install "smbclient" and "cifs-utils", is that necessary? Some of the tutorials also say to add user groups and to add settings to the firewall. I'm just using 1 user and don't have any firewalls installed, unless armbian comes with one by default.

 

I think my my service is running fine though. When I run 'sudo systemctl status smbd' it says "active (running)" in green. I can open the sbc on the network and view the shared folders, I cannot access them however. Also the sbc does not show up when I click network on windows explorer, it will however open if i type in the ip/name manually on run or the open bar, not sure if that matters.

 

I did create a new user and gave it a samba password (mouse)

 

I did chown the folder to the user and chmod 777. Here's the what comes up when i ls -al in the root directory where the folder i'm trying to share is located:

 

drwxrwxrwx  3 mouse root 4096 Jun  5 09:25 testfolder

 

 

Here's my smb.conf

 

[testfolder]

comment = Test Folder
path = /root/testfolder
browseable = yes
read only = no
writable = yes
guest ok = no
force user = mouse
create mask = 0777
directory mark = 0777

 

On path I did /root/testfolder instead of /testfolder because I also mounted a hard drive inside that folder. When I tried mapping a drive to fstab using the directory /testfolder , it kept giving me an error about folder not existing or something, but when I typed /root/testfolder , it correctly mounted the drive. I also tried using the /testfolder on the smb config and it doesn't work either.

 

These folders structures are REALLY confusing. When I ls -al in root don't see any folders like mnt var etc I only see the "testfolder" i created and a few folders starting with a period like .bashrc .... Where are the other folders located? in /root/etc ?

 

Here's the error I get when trying to access my folder. V1bzV8U.png

Link to comment
Share on other sites

Armbian Linux community supported weekly builds download

I've had this issue. I believe I resolved it by ensuring that unix password sync = no is set and then I use the utility smbpasswd to set the desired password for the SMB share.  After that my Windows 10 machine could access the share.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...