Jump to content

disks not spinning up - schematics for power supply?

Alexander Eiblinger

Recommended Posts

Hi there ...
Not sure if anyone has an idea here, but I have the following topic:

I have a helios64, equipped with 3 2.5" disk drives, running Debian 10 with Kernel 5.10.43.

Usually the system runs stable ... even for days (24/7).

But every now and then the disks "fail" - which means, during normal operation suddenly the disk turn of, linux reports "sata link down" ... and the disks are off. As if they were removed. 

If I reboot I usually here only some "klicks" ... I assume the disks try to spin up, but fail due to not enough power (?).

To recover from that situation, I usually disconnect power (incl. the internal UPS) ... try a few times, and sooner or later disks power successfully up again. Then the system run's again for a while without any issues. 

I already tried to re-cable everything, trying to ensure that the cables are properly connected, but this does not seem to help.


I assume that there is an hardware issue with the SATA power rails (both show the same effect). 
For that reason I'm looking for the schematics, to trace that a little deeper ... anyone an idea if they are somewhere available?




Link to comment
Share on other sites

I think there are open schematics for the boards.


What batch your helios comes from? The first batch was in my personal opinion less stable and the other batches had something fixed. Don't have schematics myself I should look for them too.


Also Debian? Or Amrbian, I think you should use the Armbian kernel with the patches for uboot, the think that it boots doesn't mean it has everything OK.



Edited by freed00m
Link to comment
Share on other sites

I used to have a real linux-server with raid-systems and there I had regular failures of this kind.
The problem is that the hard disks that are sold as single disks are getting worse and worse.
I had a few times even the case that a newly purchased disk was already defective. Well, I could exchange it via RMA, but that costs time and is annoying.

A while ago I discarded the server and built a NAS based on rockpi4 with sata-extension. 4x 2.5" SSD - and since then there is peace on the disk front. Everything works as desired.


Link to comment
Share on other sites

Hi Alex,


I had a simillar issue. The dmesg had SATA 1.5GB messages and decided to shutdown the SATA port. It seems connector doesn't pinch enough to keep a proper signal transport.   The NAS was a secure place and hasn't been physcaly touched for a long time.


First,I removed and plug back the impacted hardrive, nothing changed even worst 2 more went down. I did check all voltages and everything was fine.


I solved the issue by using contact cleaner fluid (stays a little bit greasy but transport signals), scrap with a special gum the harddrive connector.Everything went back to normal right after.


My final fix was to use screws to fix the hardrives in place  :)





Link to comment
Share on other sites

Just for the files, in case anyone is interested:

It seems my power rail A is faulty. I measured the voltages ... if no disk is connected I have 4.90V (which is a little less in my opinion). If I connect a disk to rail A, the power drops down to 4.10V ... I guess this is far too low to have the disk(s) start up successfully. Not sure how to deal with that at the moment.  Intended to use the 12V of rail A with a step down converter to get my needed 5V (I have 2.5" disks, no need for 12V), but it seems that the 12V are not switched of, if the helios64 is down. It still provides 12V ... 

For the moment I have removed the original SATA harness and replaced it with my own cables - having 3 disks on rail B. Works for the moment. 



Link to comment
Share on other sites

Hi Alexander,


Mine situation got worse over time. SATA1 doesn’t spin up, or if it adds with the SATA2 and emits ‘beep’ style sound generated by heads. They are both powered by the ‘b’ rail.


I used ATX 12v DC instead of the provided power supply, same results. The only way to operate requires an ATX SATA connector. My setup is 5*3″ 5, I am not sure I would be a good idea to merge them on the ‘a’ rail.


I enjoy this kind of DIY NAS and I ordered on ASRock JTX board. I might come back later to try what wrong but I am afraid some SMD on the board is involved. Today, buying a new case, add an ATX power supply is the only option.



Link to comment
Share on other sites


I have the same issue, when I've plugged into a APC powersuply that send a more reliable power the Helios64 was running pretty stable. But now I'm starting to have some disks not turning ON.
Some of the system messages:
ata2: SATA link down (SStatus 0 SControl 300)
ata2: limiting SATA link speed to 1.5 Gbps
ata3: COMRESET failed (errno=-32)

the sata 4 and 5 turns ON correctly with 6Gbs

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines