Jump to content

Armbian-Ubuntu can't boot from eMMC on Pinebook Pro


naderlane
 Share

Recommended Posts

Hello,

 

I flashed the Armbian_22.11.1_Pinebook-pro_jammy_edge_6.0.10_gnome_desktop.img file on the 64GB eMMC card of my Pinebook Pro (PBP) laptop but although the eMMC recognizes the image (the ARM logo appears on the screen for a few seconds), booting stalls at (initramfs). I proceeded as follows:

 

1) First copied the image file from my PC on a 64GB SD card which I inserted into PBP, booted it from the SD card and installed Armbian-Ubuntu without any problem.   

2) Downloaded the Armbian*.xz file a second time - this time from the SD card installation -, uncompressed it and flashed it to the eMMC with a USB-to-eMMC  adapter after having formatted and partitioned the eMMC

3) Removed the SD card and rebooted. Installation of Armbian-Ubuntu began but stalled after a few seconds at the (initramfs) prompt. Couldn't type any command (such as exit) after it.

 

PBP only boots from the SD card, but not from eMMC. Nor does it find the SSD card which I inserted with an eNVME adapter on the laptop.

 

Any hint or advice helping me to solve this issue would be very much appreciated.

 

 

Link to comment
Share on other sites

Armbian Linux community supported weekly builds download

This is a (somewhat) long standing and well known issue, check PineBook Pro subforum here, there are a number of threads about various booting issues (including eMMC specifically).

 

I think the problem (with the latest batch of PBP which were shipped, anyway) is that those came with Manjaro on the eMMC and no universal bootloader (tow boot) flashed on the SPI chip.  Well thinking about that now, I guess burning to eMMC should still work, but it doesn't for some reason.

 

Have you tried using armbian-config (and/or (the unfortunately named) nand-sata-install which can also be reached from there) to try and write the image to the eMMC?  If you already overwrote the eMMC previously I guess there is nothing left to lose.

 

I have this hardware but I just acquired an old headphone cable which I still need to fashion into a serial cable before I can proceed further.  And I have yet to collect enough 'tuits' of the round variety.

Link to comment
Share on other sites

Thank you for your reply, TRS-80, and my apologies for my late feedback. Indeed, it is possible to burn to the eMMC (with a USB-to-eMMC adapter) but I only managed to do this with the Manjaro-KDE-ARM emmc installer available on the osdn.net site (https://osdn.net/projects/manjaro-arm/storage/pbpro/kde-plasma/20.04) and not with the Armbian Ubuntu installer. Thank you also for mentioning armbian-config, which I found on github (https://github.com/armbian/config). Am giving it a try.and will let you know about the results.

 

 

Link to comment
Share on other sites

i installed Armbian on the same hardware using the armbian-config utility as i have done on my emmc devices in the past. You always boot from sd card and then use the armbian-config utility to flash the emmc using the ext4 file system. Hasn't ever failed as far as i remember, i think there were issues with some BPI products but they were worked out.

Edited by Artem Komissarov
misspelling
Link to comment
Share on other sites

@Artem Komissarov

 

Thank you for your reply, Artem. I did try to run armbian-config several times with ext4 and all other available install options but it stalled after the initial booting with the u-boot logo and before the armbian ubuntu logo appeared. During the installation phase, it did not recognize the eMMC nor any mmcblk2 partition, but only the mmcblk1 partition where armbian-ubuntu was installed from the sd card which I flashed it to.

 

Although I surely must have missed some basic command somewhere during installation, it nonetheless seems that with the factory pre-installed manjaro on Pinebook Pro any attempt at installing another OS might make the eMMC unreacheable. No resetting of the PBP will have any effect, leaving booting from the sd card as the only choice. 

 

Any further hint or advice on how to solve this issue would be very much appreciated.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...