Jump to content

Adding support for NanoPC -T6

Go to solution Solved by Efe Çetin,

Recommended Posts

I've just got a shiny new NanoPC-T6 and can get it to sort of work using a Debian image provided by the Vendor.

One issue is the HDMI output which seems to be quite unusual. I can only get one of my monitors to display an image (a 4K philips) .

The usual 1920x1080 screens such as Acer 22" don't work.

It also seems the Debian version can only run an overlay driver rather than native


I already run a NanoPi M4V2 and a NanoPi R2S under Armbian and am very happy with them and armbian


I'm happy to be a guinea pig for anyone wanting to get an armbian version running on the T6. I have some respectable machines that can do cross-compiles quite fast. 

I want to get the device to run fully native drivers and specifically have full control over the NPU cores for hard-core image applications.

Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

Thanks for the hint to the wip board config ... I did some builds in the weekend and can confirm that bookworm legacy is working pretty well - only thing was that I had to enable all the dvb drivers as they were not enabled in the kernel config ... Besides from using it as NAS with a JMB585 PCI-E card, I also want to use the T6 as VDR server with DVB-S adapters :)

I also tried edge - was compiling, but not bootable as noted here:


Link to comment
Share on other sites

Using this board with Armbian_23.08.0-trunk_Nanopct6_jammy_collabora_6.5.0-rc1.img built with Armbian build, 

everything's ok when running from SD card, but after copying stuff to eMMC with armbian-installer and running from eMMC I get things broken:

- getting lots of IO errors like this in dmesg:

I/O error, dev mmcblk0, sector 344488960 op 0x0:(READ) flags 0x0 phys_seg 1 prio class 2


Also I've noticed that the disks structure is quite different on SD and eMMC, so eMMC has extra devices:

- mmcblk0boot0

- mmcblk0boot1

and there's nothing like this on SD


Please bring on some light how to fix this.


Edited by desperex
adding dmesg output
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines