Jump to content

Rock Pi 4C+ - Top USB 3.0 Port not working (how to change to HOST mode?)


Recommended Posts



I have tried multiple Rock Pi 4+ (Plus) boards, all of them run regular Debian well, so the hardware should be good.


But when I tried Armbian, the 2 USB 3.0 ports were not working with logitech USB dongle or Samsung USB drives (which did work in regular Debian), I searched and found maybe they were in OTG mode and needed to be in HOST mode.


I tried


then System -> Hardware, then enabled:




After reboot, the bottom USB 3.0 port would start working, yet the top one still wouldn't work.


Otherwise, Armbian was the most user-friendly, fast and stable build for Rock Pi 4+, I'm absolutely loving it!


Thank you very much.



the version I tried was:



The bookworm gnome version has exactly the same issue.


The ubuntu version works perfectly after armbian-config, although it's commandline only, it would be great to have a desktop preinstalled.


Edited by cjht
Link to comment
Share on other sites

  • cjht changed the title to Rock Pi 4C+ - Top USB 3.0 Port not working (how to change to HOST mode?)

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines