Jump to content

How to enable i2c3 on Orange Pi Zero 3?


Recommended Posts

I recently picked up an Orange Pi Zero 3 and have been trying to figure out how to get the i2c pins working on the GPIO.  The pinout shows pins 2 and 3 (229 and 228 according to the orange pi version of wiringPi) being used to i2c-3.  The downloadable images seem to be hodge-podge with the orange-pi-os version based on arch linux. But their instructions appears to be based on earlier orange pi models that had an Orange Pi OS based on armbian which included a 'orangepi-config' command similar to raspi-config.  There is no orangepi-config in the arch-based Opi-OS.
A third party image from leeboby includes a current buster version of Raspbian but while it contains raspi-config, it doesn't seem to enable i2c-3 and the i2c-0 does not seem to be showing any devices I connect to pins 2 and 3.
After some armwrestling with their 'support' contact, he finally confirmed their new OS doesn't include the orangepi-config (big help - duh) but said I might want to check out their ubuntu and debian images (I'll try one of those later tonight).  In the meantime, i've already done quite a bit of configuring of a RaspAp install and some other tools such as wireguard and the like for the application I hope to put the thing to, serving as a remote-gateway when I'm in my RV. I want to be able to use the i2c to monitor the 12v battery power and solar panels on the roof, hopefully so i can keep the remote connection powered when I leave the RV set up somewhere but head back downstate to work.

dmesg shows that it detects an mv64xxx based i2c and a axp20x (AXP313a) i2c. I'm assuming the latter is used by the HDMI as running i2cdetect -l shows i2c-0 as the mv64xxx_i2c adapter and i2c-1 as DesignWare HDMI.  But, as mentioned, connecting i2c devices to pins 2 and 3 as per the gpio pinout diagram (it's rotated 180 degrees on this board) doesn't wind up showing any of my connected devices in i2cdetect.  So I think the raspbian image is trying to use whatever the OEM raspberry bcm chip config uses.

the opi wiringpi gpio readall shows GPIO 229 - wPi 0 as SDA.3 on the second pin (physical 3) and GPIO 228, wPi 1 as SCL.3 on the third pin (physical 5)

The /boot/config.txt was either non-existent or empty as after running raspi-config to try enabling i2c within it, the only line in the file was dtparam=i2c_arm=on and there is no cmdline.txt in that directory either.

I tried this config.txt setup also with no changes after rebooting:


(the commented out line being another variation I tried)

This computer uses a H618 chip similar to the banana pis. I should note their wiringpi doesn't have an H618 configuration within it's source code, but detects it as H616. (I do not know if this effects how the command works or not)

Any help getting i2c working is appreciated


Link to comment
Share on other sites

  • Werner locked this topic
This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines