Jump to content

ZFS module not built on Jammy/Bookworm legacy/edge. Solutions or alternatives ?

Go to solution Solved by Werner,

Recommended Posts

Hmm, seems i need someone holding my hand all steps of the way 😇.

Soon i'll need to pay some.. 🥰

I got my OPI5plus working from emmc with nvme-to-sata adapter on edge kernel and now i have 5 HDDs and 1 SSD connected to it. Intended for ZFS with cache...

But : ZFS module won't build. I installed linux-headers and tried # apt install zfsutils-linux zfs-dkms.


Setting up zfs-dkms (2.1.9-2ubuntu1) ...
Loading new zfs-2.1.9 DKMS files...
Building for 6.7.0-rc1-edge-rockchip-rk3588
Building initial module for 6.7.0-rc1-edge-rockchip-rk3588
configure: error:
        *** None of the expected "bops->release()" interfaces were detected.
        *** This may be because your kernel version is newer than what is
        *** supported, or you are using a patched custom kernel with
        *** incompatible modifications.
        *** ZFS Version: zfs-2.1.9-2ubuntu1
        *** Compatible Kernels: 3.10 - 6.1

Error! Bad return status for module build on kernel: 6.7.0-rc1-edge-rockchip-rk3588 (aarch64)
Consult /var/lib/dkms/zfs/2.1.9/build/make.log for more information.
dpkg: error processing package zfs-dkms (--configure):
 installed zfs-dkms package post-installation script subprocess returned error exit status 10


(It said something similar on legacy kernel ...kind of..)

The build log is not very helpful:

DKMS make.log for zfs-2.1.9 for kernel 6.7.0-rc1-edge-rockchip-rk3588 (aarch64)
Sun Jan 21 06:44:59 AM CET 2024
make: *** No targets specified and no makefile found.  Stop.

(The makefile IS there..)


The questions:

Am i doing something wrong ? Is this a known state of the zfs package for this board ?

Is there something i can do to "work around/solve/help finding a solution" ?

Are there other FS's that can make use of my disks with ~similar features as ZFS ?

Link to comment
Share on other sites

Hi Werner,

Yeah, i saw the version incompatibility. But since it was almost the same in legacy i thought it was not all about that.

I'll go look at your suggestion. Thnx for the quick response... You must work overtime!!

I'll report back when i got it working.

Link to comment
Share on other sites

  • Solution

https://openzfs.github.io/openzfs-docs/Developer Resources/Building ZFS.html


[  424.596656] zfs: module license taints kernel.
[  425.491531] ZFS: Loaded module v2.2.99-311_gd9cb42da9, ZFS pool version 5000, ZFS filesystem version 5


tested on OPi5 with kernel 6.7.1


Getting it working on legacy 5.10.y rk Android-hackedtogether kernel is a bot tougher.


Spoiler: patching method does not work anymore, at least not for me . Tested with 5.10.160...


Link to comment
Share on other sites

The getting started guide didn't help me much, rather confusing for the case of ubuntu.

The post for legacy i had read.

The problem is that my nvme-to-sata doesn't work on legacy.

I'll go and try building though i don't have much experience with that, but maybe is time to learn..

Is the licence issue a big problem ? Is the tainted kernel critical ?


Thnx for your troubles!

Gonna go to work and try...

Link to comment
Share on other sites


Was busy elsewhere for some time. Back again.

@Werner Thanx for the hints and the links. Did some reading up.

Building ZFS was straightforward. No config changes necessary, no tweaking , just clone, compile and install.

Just like my FreeBSD rig years ago 😉


some quirks:

tarball still incompatible with kernel 6.7.x, latest git version includes it so: $ git clone ... is the way

Jammy missed some "needed" package but still built and installed, Bookworm has all packages. (for both some additional packages were needed besides the ones mentioned in the README)

Tried the Kmod method first, but install failed. DKMS method worked fine. Had to remove Dracut module though before installing otherwise it needs all other packages that come with it, as dependencies.

So ZFS compiled and installed, all seemed fine.



OMV 7 does not install well on Ubuntu Jammy. It installs fine on Debian Bookworm (which is recommended).

OMV does not want to work with ZFS. Tried to offer it the created Zpool as ready to use storage but could not get it to handle it properly. Then tried OMV ZFS plugin (Dev) but does not build well on Debian 12, and starts creating downgrade demands for ZFS and upgrades of the plugin itself if you force-install the badly built plugin. Then crash and after reboot ZFS-plugin is gone. Could create btrfs RAID but was keen on iSCSI.

OMV does not do iSCSI natively, left it there . TrueNAS is only for X64_x86, no option.


Other problem:

My SATA extension board (ASM1166) holds 6 slots. I have 5 spinners and 1 500G ssd (for cache, so that the hdd's can spin down. I wanted to try while i know the downsides of such a big cache. See ZFS recommendations!).

They are powered by an external old PC PSU with enough amps on the 12V rail but almost every (re)boot 1 of the hdd's was missing, not always the same.

Tried the same PSU with a server-board with native sata and all disks would come up without a hitch.

- Could the OPI5+ have troubles initialising/managing this many spinners on boot ? Maybe it is the M.2-to-SATA extension board. Power to the disks was never off but they seemed to have speed problems and sometimes clicking (they are new and don't have this on the server-board where i placed them for now).


Gonna play some more with the OPI5+ in other missions, need to grasp the arm64 SBC platform better and it would be a shame to give it a serious job and not touch it any more as well .. ;-0

If someone wants the step by step ZFS compile write-up i can post it though it is already clearly documented, just shout.


 Started this adventure in another thread were the forum helped me with my hardware setup. i cross reference the thread for completeness:



For now my cheap Huananzhi x99-F8 (28 core Xeon, 128G DDR4, 1TB nvme) is quite happy with my Zpool. Proxmox does passthrough to TrueNAS Scale VM which in turn serves iSCSI targets back to Proxmox, Pmox BackupServer VM, Windows gaming VM (Radeon passthrough)/Jellyfin, CasaOS LXC with NextCloud and hey, why not OMV7 with Portainer? All this looped behind PfSense VM with 3 bonded double NIC's.

When will Russian Dolls manifest as Russian Roulette... Well, i'll tell you when it all breaks

I'll keep my nvme-to-sata for later use with some ssd's when i'm finished fooling around. And i'm sure i'll find another issue to create a new thread.


Thanx for your enthusiasm and hard work to make this place so pleasant!!

Edited by QuaxEros
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines