0
schnapper79

problems with latest kernel (udoo q)

Recommended Posts

hi...

 

i have some trouble compiling a new image with the latest kernel (4.2) for udoo quad.  i get an error during make

drivers/pci/access.c:493:16: error: redefinition of 'pci_vpd_f0_write'
 static ssize_t pci_vpd_f0_write(struct pci_dev *dev, loff_t pos, size_t count,

Any idea? solutions?

Share this post


Link to post
Share on other sites

It was 15.04... I can try with trusty... Just thought 15.04 was reported 'working'.

 

I know 15.10 isn't working at all, u-boot sources from udoo won't compile wit GCC 5.x...

Share this post


Link to post
Share on other sites

Hi,

 

I also have problems in compiling the latest kernel (udoo quad). It doesn't clone correctly (git issue ?!) the u-boot-neo folder content anymore (the folder is almost empty, it doesn't contain what it should), so the compiling stops with error at that point. I use Ubuntu Trusty Server x64 distro to compile the kernel.

 

I tried dozens of times, literally, with no luck, to compile a custom kernel that includes (netfilter and other repos for strongswan) for IPSEC VPN, but it always hangs at the same point, intel driver error.

 

Please help.

 

Thanks.

 

Chris

Share this post


Link to post
Share on other sites

The compiling of the new kernel was successful, but after installing the kernel debs (dtb, image, firmware, headers, etc) I wasn't able to boot the board anymore. The U-Boot says that it can't find the bzimage (the file has only 24K after installing the kernel image).

 

First error of u-boot said something like that: "it can't find a filename: that contains "dts/udoo-$$$-hdmi.dtb" in it's name. (I can't remember the full name).

 

Please help.

 

Thank you.

 

Chris

Share this post


Link to post
Share on other sites

The debs are allright now, but it seems that I still have an old problem.

 

I customized the (Vanilla) kernel and compiled it, but even if a changed in the compile.sh file 'FORCE_CHECKOUT="no"' it seems that the kernel was compiled with standard config not as I configured it in the configuration stage, after installing all debs, I couldn't see the modules I included.

 

Please help.

 

Thank you.

 

Chris

Share this post


Link to post
Share on other sites

Are you using our testing branch? (master) We are still fixing bugs ... generally works.

 

Out of the default config try to compile with this:

KERNEL_CONFIGURE="yes"
USE_CCACHE="no" # i suspect this is the root of your problems and must be disabled if we re-configuring the kernel

Share this post


Link to post
Share on other sites

FORCE_CHECKOUT affects only sources, git shouldn't touch config file.

Kernel config is overwritten every time on recompilation, it's not enough to tweak it only once. Also I don't see how ccache can interfere with this.

Try setting KERNEL_KEEP_CONFIG=yes (it should work on both second and master branches), and after installation check if config file in /boot still has your changed settings.

Share this post


Link to post
Share on other sites

SOLVED!

 

Thanks for suggestions to both of you (Igor and Zador)

 

I finally succeeded! It worked only on master branch (Vanilla Kernel), on the second one it failed at the u-boot compile time (both kernels) (I will come back later with specific error).

 

Yes, in /boot the config file is my custom one, as it should be.

 

For safety I followed both of your suggestions:

 

1. KERNEL_CONFIGURE="yes"
2. USE_CCACHE="no"

3. KERNEL_KEEP_CONFIG="yes"

 

Compiled the new kernel, and It worked perfectly.

 

I hope this will help others who are trying to compile their own custom kernel.

 

Greetings.

 

I will come back with more feedback later.

 

Thanks alot to both of you.

 

Chris

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
0