Wifi mt7601Usta problem


Recommended Posts

dmesg log:

ci_irq: highspeed device disconnect

[ 1150.728627] ehci_irq: highspeed device connect

[ 1151.000116] usb 3-1: new high-speed USB device number 3 using sunxi-ehci

[ 1151.294344] usbcore: registered new interface driver rt2870

 

lsmod log:

g@orangepipc:/$ lsmod

Module Size Used by

mt7601Usta 561549 0

rndis_host 5140 0

cdc_ether 3679 1 rndis_host

usbnet 14096 2 rndis_host,cdc_ether

cdc_acm 15280 0

mali_drm 2732 1

drm 178255 2 mali_drm

usblp 10048 0

pcf8591 3363 0

bmp085 3487 0

mali 123146 0

ump 29379 3 mali

btrfs 712409 0

 

g@orangepipc:/$ ip link

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN mode DEFAULT group default

link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

2: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT group default qlen 1000

link/ether 46:91:e3:79:bd:fd brd ff:ff:ff:ff:ff:ff

3: tunl0: <NOARP> mtu 1480 qdisc noop state DOWN mode DEFAULT group default

link/ipip 0.0.0.0 brd 0.0.0.0

9: ra0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000

link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff

 

 

 

Still my wifi doesnt work .It used to work by making my own by cloning from git in debian jessy but in xenial , it is not working at all.

I clone it from here :

sudo apt-get install linux-headers-generic build-essential git

sudo apt-get install git

git clone https://github.com/flexiti/mt7601.git 

cd mt7601

make clean 

make

sudo make install

sudo mkdir -p /etc/Wireless/RT2870STA/

sudo cp RT2870STA.dat /etc/Wireless/RT2870STA/

sudo modprobe mt7601Usta

 

 

my /etc/network/interfaces/ gives

 

 

# Wireless adapter #1
allow-hotplug ra0
#auto ra0
#iface ra0 inet static
#	wpa-ssid SSID
#	wpa-psk xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
# to generate proper encrypted key: wpa_passphrase yourSSID yourpassword

g@orangepipc:~$ ifconfig ra0
ra0       Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)



whats wrong with me ? in nmtui it is not visible . Iam using orange pi pc. kindly help.
Link to post
Share on other sites
Donate and support the project!

You mean all of this ?

# Wired adapter #1
allow-hotplug eth0
no-auto-down eth0
iface eth0 inet dhcp
#address 192.168.0.100
#netmask 255.255.255.0
#gateway 192.168.0.1
#dns-nameservers 8.8.8.8 8.8.4.4
#	hwaddress ether # if you want to set MAC manually
#	pre-up /sbin/ifconfig eth0 mtu 3838 # setting MTU for DHCP, static just: mtu 3838


# Wireless adapter #1
allow-hotplug ra0
#auto ra0
#iface ra0 inet dhcp
#	wpa-ssid mijlu
#	wpa-psk queens123
# to generate proper encrypted key: wpa_passphrase mijlu queens123


# Local loopback
auto lo
iface lo inet loopback
Link to post
Share on other sites

clone again but doesnt work my nmcli :

@orangepipc:~$ sudo nmtui
[sudo] password for g: 

(nmtui:878): libnm-CRITICAL **: nm_utils_ssid_to_utf8: assertion 'ssid != NULL' failed
g@orangepipc:~$ sudo nmtui
g@orangepipc:~$ sudo nmcli
Usage: nmcli [OPTIONS] OBJECT { COMMAND | help }

OPTIONS
  -t[erse]                                   terse output
  -p[retty]                                  pretty output
  -m[ode] tabular|multiline                  output mode
  -c[olors] auto|yes|no                      whether to use colors in output
  -f[ields] <field1,field2,...>|all|common   specify fields to output
  -e[scape] yes|no                           escape columns separators in values
  -a[sk]                                     ask for missing parameters
  -s[how-secrets]                            allow displaying passwords
  -w[ait] <seconds>                          set timeout waiting for finishing operations
  -v[ersion]                                 show program version
  -h[elp]                                    print this help

OBJECT
  g[eneral]       NetworkManager's general status and operations
  n[etworking]    overall networking control
  r[adio]         NetworkManager radio switches
  c[onnection]    NetworkManager's connections
  d[evice]        devices managed by NetworkManager
  a[gent]         NetworkManager secret agent or polkit agent
  m[onitor]       monitor NetworkManager changes

g@orangepipc:~$ sudo nmcli g
STATE         CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN    
disconnected  none          enabled  enabled  enabled  enabled 
g@orangepipc:~$ sudo nmcli c
NAME   UUID                                  TYPE             DEVICE 
Wifi1  26a2722c-e968-4e8e-89b4-e01de9e43944  802-11-wireless  --     
g@orangepipc:~$ sudo nmcli r
WIFI-HW  WIFI     WWAN-HW  WWAN    
enabled  enabled  enabled  enabled 
g@orangepipc:~$ sudo nmcli c
NAME   UUID                                  TYPE             DEVICE 
Wifi1  26a2722c-e968-4e8e-89b4-e01de9e43944  802-11-wireless  --     
g@orangepipc:~$ sudo nmcli d
DEVICE  TYPE      STATE         CONNECTION 
eth0    ethernet  disconnected  --         
lo      loopback  unmanaged     --         
tunl0   unknown   unmanaged     --         
g@orangepipc:~$ sudo nmcli ds
Error: Object 'ds' is unknown, try 'nmcli help'.
g@orangepipc:~$ sudo nmcli a
nmcli successfully registered as a NetworkManager's secret agent.

** (process:927): WARNING **: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
  

Link to post
Share on other sites
1 hour ago, premo said:

Do you want  me to put the file in lib/config/network/interfaces.network-manager

 

No, just use an empty /etc/network/interfaces or comment at least the ra0 line out. Then restart the board, run

TERM=linux sudo nmtui

and in case it still doesn't work follow the usual procedure: https://docs.armbian.com/User-Guide_Fine-Tuning/#how-to-provide-boot-logs-for-inspection

Link to post
Share on other sites

Eg. try etc/network/interfaces/:

Quote

 

auto ra0

alow-hotplug ra0

iface ra0 inet static

address 192.168.0.100

netmask 255.255.255.0

gateway 192.168.0.1

wpa-ssid 'name of wlan ssid you are connected to'

wpa-psk 'Your wlan password you are connected to'

dns-nameservers 8.8.8.8

 

 

end restart

 

 

 

Link to post
Share on other sites
Guest
This topic is now closed to further replies.