Jump to content
  • 0

Orange Pi Pc + hangs or will not boot without hmdi


gullyg
 Share

Question

Hi,

I have an Oracle PI PC+ which will not boot without the hdmi connected.  If you disconnect the hdmi once the board has booted it crashes or at least stops responding to ping/ssh over the ethernet.

 

I've used pretty much all the builds I can find on armbian.com including the nightly builds with don't show a display at all but still fail without the hdmi.  I've also tried booting from SD card and the emmc almong will messing with the /boot config files such as setting the console to serial and can't see anything interesting in the messages file.

 

It shouldn't be a power issue as I'm using an Anker 2.4a PSU but I've tried other PSUs as well with no luck.

 

Thanks

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

That is a bit strange ...

I did my own build for OrangePiPCPlus 2 days ago, and this build is running fine on my 4 boards which are all headless.

Did you attached an Debug USB-TTL to see what kind of errors occured ?

Link to comment
Share on other sites

Order Armbian Linux merch!

  • 0

So after a bit of scouting about I've managed to get the OTG port to act as a serial connection using https://oshlab.com/enable-g_serial-usb-otg-console-orange-pi-armbian/

But
 this doesn't work either when attempting to boot without hdmi suggesting the kernel isn't getting very far - neither is there any network activity lights. 

 

Searching the internet it appears there were some ripi boards suffering this at out point as a bug but updating the firmware sorted the issue...

 

Unfortunately I seem to be "unique" with this issue.  Hopefully getting serial off the gpio ports will help but I'm not feeling it.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...