System time always wrong after boot - after upgrade from 4.7 to 4.81


Recommended Posts

Hi Igor,

my Cubox-i4Pro worked perfectly fine with your Armbian Debian Jessie, until I upgraded from 4.7 to 4.81.

After the upgrade was performed today, the system time is always wrong after boot, it is always set to Jan 1 01:00:00 1970.

Setting the system time correctly does not help, after reboot it is wrong again.

I didn't observe this behavior before upgrade, the system time just used to work without any attention needed.

Nothing else was changed in the system, only the upgrade of Armbian was done to ver 4.81.

So I'm wondering what went wrong with the upgrade.

Hardware time is always correct, syncing system time to hardware time does not survive boot.

I tried to delete and re-create /etc/adjtime, it does not help.

I want to avoid workarounds like cron or ntp, if it worked properly before the upgrade it should just work I assume.

 

These packages were upgraded :

 

Start-Date: 2015-12-28  20:05:14
Commandline: apt-get -y install linux-dtb-cubox
Upgrade: linux-dtb-cubox:armhf (4.70, 4.81)
End-Date: 2015-12-28  20:05:31

Start-Date: 2015-12-28  20:05:49
Commandline: apt-get -y install linux-firmware-image-cubox
Upgrade: linux-firmware-image-cubox:armhf (4.70, 4.81)
End-Date: 2015-12-28  20:05:57

Start-Date: 2015-12-28  20:06:24
Commandline: apt-get -y install linux-headers-cubox
Upgrade: linux-headers-cubox:armhf (4.70, 4.81)
End-Date: 2015-12-28  20:20:16

Start-Date: 2015-12-28  20:20:57
Commandline: apt-get -y install linux-image-cubox
Upgrade: linux-image-cubox:armhf (4.70, 4.81)
End-Date: 2015-12-28  20:29:25

Start-Date: 2015-12-28  20:29:42
Commandline: apt-get -y install linux-jessie-root-cubox-i
Upgrade: linux-jessie-root-cubox-i:armhf (4.70, 4.81)
End-Date: 2015-12-28  20:29:48
 

 

The unit is Cubox-i4Pro with Armbian Debian Jessie.

 

Please let me know if you need some further information.

 

Thanks!!

 

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

To be more specific - wrong RTC time with mainline kernel can cause all kind of issues from network problems to complete non-booting system. As an experiment solution setting system time from RTC by kernel at early boot was disabled, instead it should be done with fake-hwclock, and later time should be actualized by ntp client.

So for now please install fake-hwclock package and make sure your ntp client works.

Link to post
Share on other sites

[sOLVED]

 

Many thanks to both of you!

 

I've done the following steps, just for your records:

 

- Rebooted the unit

- System time incorrect (January 1970)

- Manually synced system time to hardware clock, in order to get the internet connection through OpenVPN working

- Installed fake-hwclock package (current version is 0.9): apt-get install fake-hwclock

- Rebooted the unit

- System time incorrect (January 1970)

- Manually synced system time to hardware clock, in order to get the internet connection through OpenVPN working

- Synced system time and hardware clock using NTP

- Rebooted the unit

- System time correct after boot

- OpenVPN works

 

Thank you once again!

You can close this thread.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.