[Solved] CRON and ntpd repeated fails in log


Recommended Posts

Hi,

Noobee here.

 

I'm using a NanoPi NEO with the latest legacy image updated.  Using ssh to access device.

Linux Lap 3.4.113-sun8i #4 SMP PREEMPT Wed Nov 22 13:45:28 CET 2017 armv7l armv7l armv7l GNU/Linux

 

In the journalctrl log I'm getting repeated failures for ntpd and cron about every minute.

 

1)  The router that I'm connected to is IPv4 only.  In nmtui I'v set the connection to ignore IPv6, but it seems that IPv6 has not been disabled.

A IPv6 IP address has been assigned to the wireless interface.  Should I be doing something else?

 

2)  Cron is constantly doing something with armbian-updates.  Is this normal??

 

diagnosis information will now be uploaded to http://sprunge.us/VfcK

 

Regards,

Gord_W

 

 

Dec 12 08:04:22 Lap ntpd[902]: bind(22) AF_INET6 fe80::42a5:efff:fed2:ee52%4#123 flags 0x11 failed: Cannot assign req
Dec 12 08:04:22 Lap ntpd[902]: unable to create socket on wlx40a5efd2ee52 (400) for fe80::42a5:efff:fed2:ee52%4#123
Dec 12 08:04:22 Lap ntpd[902]: failed to init interface for address fe80::42a5:efff:fed2:ee52%4
Dec 12 08:05:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:05:01 Lap CRON[9046]: pam_unix(cron:session): session opened for user root by (uid=0)
Dec 12 08:05:01 Lap CRON[9047]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Dec 12 08:05:01 Lap CRON[9046]: pam_unix(cron:session): session closed for user root
Dec 12 08:06:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:06:22 Lap ntpd[902]: bind(22) AF_INET6 fe80::42a5:efff:fed2:ee52%4#123 flags 0x11 failed: Cannot assign req
Dec 12 08:06:22 Lap ntpd[902]: unable to create socket on wlx40a5efd2ee52 (401) for fe80::42a5:efff:fed2:ee52%4#123
Dec 12 08:06:22 Lap ntpd[902]: failed to init interface for address fe80::42a5:efff:fed2:ee52%4
Dec 12 08:07:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:08:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:08:22 Lap ntpd[902]: bind(22) AF_INET6 fe80::42a5:efff:fed2:ee52%4#123 flags 0x11 failed: Cannot assign req
Dec 12 08:08:22 Lap ntpd[902]: unable to create socket on wlx40a5efd2ee52 (402) for fe80::42a5:efff:fed2:ee52%4#123
Dec 12 08:08:22 Lap ntpd[902]: failed to init interface for address fe80::42a5:efff:fed2:ee52%4
Dec 12 08:09:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:10:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:10:22 Lap ntpd[902]: bind(22) AF_INET6 fe80::42a5:efff:fed2:ee52%4#123 flags 0x11 failed: Cannot assign req
Dec 12 08:10:22 Lap ntpd[902]: unable to create socket on wlx40a5efd2ee52 (403) for fe80::42a5:efff:fed2:ee52%4#123
Dec 12 08:10:22 Lap ntpd[902]: failed to init interface for address fe80::42a5:efff:fed2:ee52%4
Dec 12 08:11:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:12:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:12:22 Lap ntpd[902]: bind(22) AF_INET6 fe80::42a5:efff:fed2:ee52%4#123 flags 0x11 failed: Cannot assign req
Dec 12 08:12:22 Lap ntpd[902]: unable to create socket on wlx40a5efd2ee52 (404) for fe80::42a5:efff:fed2:ee52%4#123
Dec 12 08:12:22 Lap ntpd[902]: failed to init interface for address fe80::42a5:efff:fed2:ee52%4
Dec 12 08:13:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:14:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:14:22 Lap ntpd[902]: bind(22) AF_INET6 fe80::42a5:efff:fed2:ee52%4#123 flags 0x11 failed: Cannot assign req
Dec 12 08:14:22 Lap ntpd[902]: unable to create socket on wlx40a5efd2ee52 (405) for fe80::42a5:efff:fed2:ee52%4#123
Dec 12 08:14:22 Lap ntpd[902]: failed to init interface for address fe80::42a5:efff:fed2:ee52%4
Dec 12 08:15:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:15:01 Lap CRON[9100]: pam_unix(cron:session): session opened for user root by (uid=0)
Dec 12 08:15:01 Lap CRON[9101]: (root) CMD (command -v debian-sa1 > /dev/null && debian-sa1 1 1)
Dec 12 08:15:01 Lap CRON[9100]: pam_unix(cron:session): session closed for user root
Dec 12 08:16:01 Lap cron[455]: (*system*armbian-updates) INSECURE MODE (group/other writable) (/etc/cron.d/armbian-up
Dec 12 08:16:22 Lap ntpd[902]: bind(22) AF_INET6 fe80::42a5:efff:fed2:ee52%4#123 flags 0x11 failed: Cannot assign req
Dec 12 08:16:22 Lap ntpd[902]: unable to create socket on wlx40a5efd2ee52 (406) for fe80::42a5:efff:fed2:ee52%4#123
D

Edited by Gord_W
Change to Solved
Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

Thanks Igor.

 

For Reference:

 

chmod 644 /etc/cron.d/armbian-updates  has stopped the INSECURE MODE problem.

 

For item 1)  above to stop IPv6 see http://www.binarytides.com/disable-ipv6-ubuntu/

 

I used this method:

Method 1 - Disable from sysctl

The first method to disable Ipv6 is to edit kernel level parameters via sysctl interface.

 

The kernel parameters that enable ipv6 are as follows

$ sysctl net.ipv6.conf.all.disable_ipv6

net.ipv6.conf.all.disable_ipv6 = 0

$ sysctl net.ipv6.conf.default.disable_ipv6

net.ipv6.conf.default.disable_ipv6 = 0

$ sysctl net.ipv6.conf.lo.disable_ipv6

net.ipv6.conf.lo.disable_ipv6 = 0

 

Note that the variables control "disabling" of ipv6. So setting them to 1 would disable ipv6
Edit the file - /etc/sysctl.conf

$ sudo nano /etc/sysctl.conf

 

And fill in the following lines at the end of that file

 

# IPv6 disabled

net.ipv6.conf.all.disable_ipv6 = 1

net.ipv6.conf.default.disable_ipv6 = 1

net.ipv6.conf.lo.disable_ipv6 = 1

 

Save the file and close it. Restart sysctl with

$ sudo sysctl -p

 

Check the output of ifconfig again and there should be no ipv6 address

 

Thanks,

Gord_W

Link to post
Share on other sites

This whole Armbian thing is a common work and we already work at maximum capacity. Try to add this feature on your own - you only need to check this section: https://github.com/armbian/config/blob/dev/debian-config-jobs#L728-L736 and this line: https://github.com/armbian/config/blob/dev/debian-config-submenu#L524 as a similar example how to add a feature to the config. The rest you do with bash utilities. Use this method: https://docs.armbian.com/Process_Contribute/

Link to post
Share on other sites
Guest
This topic is now closed to further replies.