Halon314

Initial login (via SSH) can't set password

Recommended Posts

I have Armbian (headless/server edition, no GUI) booting nicely on an OrangePi.
I got the IP address from my router and SSH'd into the Pi with success.

When I log in, I am asked to change the password.  After I do,  I receive no error message or indication that the password changed, I am simply logged out.

When I reconnect, the password is back to the default of 1234 and it asks me to change the password.  I'm stuck in this loop.

How do I change the password and get it to save?

Share this post


Link to post
Share on other sites

did you type 1234 two times? first for login, second when you wanna change the password. A login should look like:

  1. root --> 1234
  2. 1234 -->new password --> confirm new password

If I have it right in mind ssh kicks you out when you miss to type in the old password (1234) when you wanna change it.. 

Share this post


Link to post
Share on other sites

Yes.  It prompts me to enter the old password (1234), then create a new password, then confirm the new password.  After I complete these three steps, I get booted off..

Share this post


Link to post
Share on other sites

Interesting.   I  DID  follow that, having used Etcher to write the image to my microSD card.

I decided to try the F3 tool to confirm the stability of my card.  It failed.
I guess I'll be going out tomorrow to find another card.

Thanks for the assist!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now