[SOLVED] Broken repositories


I'mTO1
 Share

0

Recommended Posts

Hi

I want to install some packages, but it not found on sources. When i do update repositories by sudo apt update command, the following messages shown that means the repositories is broken.

Err:1 http://httpredir.debian.org/debian stretch InRelease
  Could not resolve 'httpredir.debian.org'
Err:2 http://httpredir.debian.org/debian stretch-updates InRelease
  Could not resolve 'httpredir.debian.org'
Err:3 http://httpredir.debian.org/debian stretch-backports InRelease
  Could not resolve 'httpredir.debian.org'
Err:4 http://security.debian.org stretch/updates InRelease
  Could not resolve 'security.debian.org'
Err:5 http://apt.armbian.com stretch InRelease
  Could not resolve 'apt.armbian.com'
Reading package lists... Done
Building dependency tree
Reading state information... Done
3 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Failed to fetch http://httpredir.debian.org/debian/dists/stretch/InRelease  Could not resolve 'httpredir.debian.org'
W: Failed to fetch http://httpredir.debian.org/debian/dists/stretch-updates/InRelease  Could not resolve 'httpredir.debian.org'
W: Failed to fetch http://httpredir.debian.org/debian/dists/stretch-backports/InRelease  Could not resolve 'httpredir.debian.org'
W: Failed to fetch http://security.debian.org/dists/stretch/updates/InRelease  Could not resolve 'security.debian.org'
W: Failed to fetch http://apt.armbian.com/dists/stretch/InRelease  Could not resolve 'apt.armbian.com'
W: Some index files failed to download. They have been ignored, or old ones used instead.

Also i tried sudo apt update --fix-missing and sudo aptitude update or sudo apt-get update but nothing changed.

I'm using Armbian_5.38_Cubietruck_Debian_stretch_next_4.14.14

How can i fix this? Is there a new source list to replace?

Thanks.

Link to post
Share on other sites

Donate and support the project!

1 minute ago, Igor said:

Problem is DNS related. If you are getting IP via DHPC server, which is default, this is what you need to do:


rm /etc/network/interfaces
reboot

I'm using static IP, but my internet connection is shared true another Ethernet connection that gets IP from DHCP server.

is it works for my situation?

 

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

0