0
greenais

Is it possible to mount eMMC in SD-booted image somehow?

Recommended Posts

Board OrangePi+2E,  Debian on SD was configured/tested, then nand-instaled to eMMC.
Worked as Nextcloud headless server like a charm for more than year (thanks Armbian once again), but suddenly got stuck in boot with quite strange simptoms (read on attacched for exploration HDMI):
couple of "sunxi_i2c_do_xfer incomplete xfer" errors

/swap creation takes ~100 seconds

then complete hang on Ethernet init

 

The only thing I can suspect is some corruption in filesystem(s) on eMMC, but I see no chance to investigate this further as boot from it hangs completely.

 

Fresh SD with mainline Debian boots and works with no issues, so the rest of the board seems to be Ok.

But there on eMMC I left my configs (yes, I've already pulled my hair for not making backups in time - one painful lesson more),

so the question is as such:

 

is there any chance to mount eMMC filesystem in SD-booted image?
 

 

Share this post


Link to post
Share on other sites
5 hours ago, greenais said:

is there any chance to mount eMMC filesystem in SD-booted image?


Yes. Just use an image for Orange Pi 2e. If your eMMC is not seen under /proc/partitions ... it's dead.  If you see it, try to fsck and then mount ... SD cars is usually /dev/mmcblk0 and /dev/mmcblk1 eMMC or vice versa. Just try to mount its first and only partition: mount /dev/mmcblk0p1 /mnt 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
0