failed to modify connection with "nmcli" command, connection is read-only


Marco-Omniabit
 Share

0

Recommended Posts

Hello,

 

in the company where I work, a nanopi M1 plus was purchased and we are developing a firmware to run on the device. In our code we need to change the settings of the active wired connection at that time, but we can not do it due to an error. If, for example, we use the following command:

nmcli connection modify 'Ifupdown (eth0)' ipv4.method auto

The following error message is returned.

Error: failed to modify connection 'Ifupdown (eth0)': Connection is read-only

The command is executed correctly if the connection is not managed by NetworkManager, so when in the file: "NetworkManager.conf" the "managed" parameter is set to false. We had to set it to true because otherwise, by changing the ethernet cable and inserting another of another subnet, we realized that the device keeps the old IP address and therefore is unreachable. So how could we solve that problem?

 

Regards 

Marco

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Guest
This topic is now closed to further replies.
 Share

0