0
nurdle

How can I disable IPv6 or use temporary addresses. Regular methods don't work. [SOLVED]

Recommended Posts

I've tried various methods. None work.

 

What are the recommended Armbian ways to
a) enable IPv6 temporary addresses

b) disable IPv6

 

Thank you.

Share this post


Link to post
Share on other sites

I suppose one could go into network manager and set ipv6 to link-local only, this will result in your device getting an fe80::/64 address - which is handy for mDNS/Avahi on the local subnet...

 

nmtui_ipv6_linklocal.png.4f48694c670ecfd772825a2c68c6042e.png

Share this post


Link to post
Share on other sites

It wont let me save that setting.

I get:

Quote

Unable to save connection:
ipv6.addresses: this property is not
allowed for 'method=link-local'

 

Share this post


Link to post
Share on other sites

After hours, literally *hours*, researching this IPv6 crud I think I have it.

Apparently Network Manager overrides the regular IPv6 settings configured in `/etc/sysctl.conf`.

So its a two part fix.

 

First setting `method` to `ignore` is part of the solution (see sfx2000's screenshot)

That takes IPv6 out of Network Manager's control.
BUT `nmtui` wouldn't let me save that setting... I've no idea why.
So I had to do it manually

    sudo nano /etc/NetworkManager/system-connections/eth0
    ---[snip]---
    
    [IPv6]
    method=ignore

 

Then all the regular `/etc/sysctl.conf` changes seem to work.
I've tested Privacy extensions and disabling IPv6.


Hope this saves someone else wasting hours of their life they'll never get back :rolleyes:

Share this post


Link to post
Share on other sites

Thanks, sfx2000.  But I'd already "disabled" IPv6 using that method.
On my first Armbian setup attempts, no matter what I did, my system never got an IPv4 address.
It only ever had an IPv6 (despite my network being IPv4.)
Eventually I stumbled on that `armbian-config` option.

Once "disabled" it allowed the system to get an IPv4.  But despite what it says, it didn't "disable" IPv6 system wide.
Tools like `ip addr` and `ifconfig` showed it still had IPv6 active.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0