Jump to content

Olimex Lime 2 - Build from scripts hangs at boot


Recommended Posts

Hello there,

 

I am trying to build a custom armbian image using instructions here http://www.armbian.com/using-armbian-tools/, because I need to enable additional module for Philips webcam, not included in stock one.

 

I have built the compile environment, run the script, added my modules and compiled, generating the entire image. Once I flash and boot from it though, Uboot hangs while saying "booting the kernel"

 

I have tried release 5.00 and 5.06, using Debian Wheezy and Jessie, with the same result. I have also tried flashing the stock image and then just replace kernel packages I had built, because I thought the problem could have to do with systemd.

 

As latest pre-built image is 4.5, I suspect I have leaped too much ahead with the kernel version. Having the latest kernel is not a requirement for me, so if I could just build my custom image based on 4.5, or using the same kernel this would be great, but I could not find this release here https://github.com/igorpecovnik/lib/releases

 

 

Any suggestions about how to proceed?

 

 

Thanks in advance for any help, and many thanks to Igor for leading this great project.

 

 

Antonio

 

Link to comment
Share on other sites

Check forum guidelines to use maximum potential!

I could solve my issue this way:

  • install stock image
  • compile my custom kernel only, instead of entire image
  • replace kernel into stock image ONLY. Before I had also replaced u-boot with the one coming from compilation

Now system works properly and I am able to recognize my webcam. This means my issue was caused by u-boot, but I really cannot tell why.

 

 

All the best

 

Antonio

Link to comment
Share on other sites

22 hours ago one u-boot related fix was added.

 

https://github.com/igorpecovnik/lib/commit/e99abfed490d28181ec10eff99c9ae2ccb8ec9ac

 

2 days ago I add a workaround

https://github.com/igorpecovnik/lib/commit/f980a00c12dd83c0a71ae41a0ad3daa75a51ae40

 

more than 2 days ago u-boot (network init) was broken, at least on some boards.

 

When exactly did you build?

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...