0
dony71

no hdmi sound device on banana -pi-m2+ using armbian 5.65 [SOLVED]

Recommended Posts

i just upgrade from jessie to armbian stretch (5.65)

i check aplay -l, why only shows audio codec?

anybody help?

 

root@bananapim2plus:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Codec [H3 Audio Codec], device 0: CDC PCM Codec-0 []
  Subdevices: 1/1
  Subdevice #0: subdevice #0

 

 

Share this post


Link to post
Share on other sites
5 hours ago, Igor said:


Nobody will even look if you don't add logs.

syslog attached below

my guess is no hdmi driver in kernel

i thought release version should include this?

btw, i have also similar issue with pcm5102 dac via i2s

link for this issue:

 

 

syslog.bak

Share this post


Link to post
Share on other sites
On 11/10/2018 at 12:12 PM, Igor said:


Nobody will even look if you don't add logs.

 

@Igor can you tell me what's the name of file for HDMI audio driver module?

I have compiled kernel and have setting below for HDMI audio

CONFIG_DRM_DW_HDMI=m
CONFIG_DRM_DW_HDMI_AHB_AUDIO=m
CONFIG_DRM_DW_HDMI_I2S_AUDIO=m
CONFIG_DRM_DW_HDMI_CEC=m
 

Share this post


Link to post
Share on other sites

I think HDMI audio driver should be snd_soc_hdmi_codec ?

This is strange cause I can see from lsmod driver is already loaded

Also I load also snd_soc_pcm512x, but aplay -l still showing none of sndhdmi and snddaudio

Anybody help??

system diagnostic information:

http://ix.io/1rPj

 

Share this post


Link to post
Share on other sites
On 11/13/2018 at 9:28 PM, Igor said:

 

There is already patch in armbian and it's working now

Just need to enable dts sound section

 

---------------------------------------------------------------------

        sound {
                compatible = "simple-audio-card";
                simple-audio-card,format = "i2s";
                simple-audio-card,name = "allwinner,hdmi";
                simple-audio-card,mclk-fs = <0x100>;
                #status = "disabled";
                status = "okay";
                linux,phandle = <0x3f>;
                phandle = <0x3f>;

                simple-audio-card,codec {
                        sound-dai = <0x2>;
                };

                simple-audio-card,cpu {
                        sound-dai = <0x3>;
                };
        };

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0