0
pazzoide

Banana PI - ghostly swap

Recommended Posts

Hi on my Banana PI I have set no swapfile/partition since I never gonna use swapspace ram is gonna be enough. When I reboot I always find 499MB of swap

 

 swapon -s
Filename                                Type            Size    Used    Priority
/dev/zram1                              partition       255728  67052   5
/dev/zram2                              partition       255728  66836   5

But I can find no entry of /dev/zram1 nor /dev/zram2 in /etc/fstab. Can anybody explain me how is this possibile? And how to manage those partitions?

 

I found another /dev/zram0 which I think has to deal with log2ram since it is mounted on /var/log, is this correct?

 

Thanks

 

Share this post


Link to post
Share on other sites
Want Armbian t-shirt or a cup?

Thank you, what I don't understand is where does this 500MB of zram space come from?

 

It is not a chip on the board as of producer's specs http://www.lemaker.org/product-bananapi-specification.html

It should not be part of the 1GB ram, since if I swapoff I can see the "Swp bar" (zram) dropping to 0 and filling the "Mem bar" with the missing MegaBytes.

 

Cattura.PNG.bb40c4e11c22afaac88109eb500cc75d.PNG

 

So where does it come from???

Share this post


Link to post
Share on other sites
4 hours ago, pazzoide said:

So where does it come from???

 

armbian-zram-config.service, which is closely linked to armbian-ramlog.service

 

Doesn't hurt to keep them enabled, but if one wants, you can disable them using systemctl disable <name of service>

 

There's benefit to keeping them on - reduces writes to the flash device.

Share this post


Link to post
Share on other sites
8 hours ago, pazzoide said:

what I don't understand is

two (2) posts above yours there is a link. Did you read that thread ?

 

Share this post


Link to post
Share on other sites
On 12/21/2018 at 3:48 AM, sfx2000 said:

 

armbian-zram-config.service, which is closely linked to armbian-ramlog.service

 

Doesn't hurt to keep them enabled, but if one wants, you can disable them using systemctl disable <name of service>

 

There's benefit to keeping them on - reduces writes to the flash device.

Thank you so much!

It's worked.

 

at the end of 【/usr/lib/armbian/armbian-zram-config】

add #   

 

like this:

case $1 in
123     *start*)
124     #   activate_zram_swap
125         activate_ramlog_partition
126         activate_compressed_tmp
127         ;;
128 esac
 

it close zram_swap.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0