banana-pi r2 / dhclient with isp

Recommended Posts

I just tried to get the dhclient on eth0 to communicate with my ISP (which uses dhcp).


On OpenWrt, this works with no problem. However, all I got on the bpi-r2 (eth0) was a 169.x (no answer) address.


For the internal network, the dhclient works just fine.


I have already tried using eth0 in systemd's network and outside of it (using dhclient). No communication in both cases.


ta, t.

Link to post
Share on other sites
Donate and support the project!

as far as I know, openWRT uses still the 4.9 kernel right? And if I'm not completely wrong the 4.9 kernel uses not a DSA driver. Maybe @frank-w can comment on this cause he knows the BSP sources a way better than I do. I only did the 'board bring up' with mainline kernels (starting somewhere at 4.17 now at 4.19).. :PDSA is actually a bit messy at the moment and it's not that easy to give you some guidance (e.g. I've fiber so I can't test a lot of things..)

eth0 isn't really 'wired out'.. in a picture eth0 are the traces between the SoC and the DSA chip (mt7530). So I assume (and that's pure assumptions) it's likely a configuration issue. The current configuration ( might not be sufficient for you (it's a it just works configuration and there's a lot room for improvements ;) ).  Maybe pick out one interface (e.g. wan) from the bridge and give it a try?

Link to post
Share on other sites

official lede from sinovoip still uses 4.9, but there is imho also a dsa-driver (backported from 4.1x afair),

there is openwrt with 4.14 which includes Patches for bpi-r2 (where i've got my Patches for second gmac).


if you have a dsa-driver (you see interfaces wan,lan0-lan3) you cannot work on eth0/eth1 (these are only the ethernet-connections between switch [mt7530] and SOC/Main-CPU [mt7623]), only bring them up...ip-config has to be done on dsa-interfaces.

Link to post
Share on other sites

you have not to care about DSA, only that it is there and you have to operate on virtual interfaces wan,lan0-3 instead of ethx. vlan have also time (most people don't need it), first get basic network-setup working.


so just bring eth0/1 only up and configure the wan/lan-ports


btw. it's new to me that there is a DSA-Driver for Bpi-R1, i only have seen swconfig-configurations to access ports separately

Link to post
Share on other sites

that's why I highlighted you here.. you know the BSP and 'out of armbian' world better for the R2 than me. :) For the R2 Armbian uses networkd for configuration the best tutorials I found for it is found in archs wiki (they should print it in a book and call it linux for dummies :lol:)

Currently I don't spend much time in the R2, it's just that time is limited. I had a patch prepared for the second gmac (based on franks work), it shows up in ip a but networkd doesn't like it.. Maybe I've a look into it in the next weeks.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.