Jump to content

avahi : armbian 5.73 on bananapi (m1) not "working"


Recommended Posts

Banana Pi (original "model 1") A20

Was running flawlessly on Xenial - latest updates - almost everything worked (I run it on a LiPo battery to transport back and forth from work to keep my Resilio Sync data "in sync")

Resilio seems to work fine - except in Bionic I can't use avahi to resolve names on my LAN...  this worked in Xenial on the same hardware.

The reason I decided to try out Bionic?  Couldn't find a resource to upgrade from OpenSSH 7.2 to 7.3 or greater (I'm making heavy use of features not available in OpenSSH 7.2 on my other machines).

I've tried tweaking my /etc/nsswitch.conf file to no avail...

Sheesh - "avahi" just worked out of the box on Armbian Xenial - and it works out of the box on Bionic on x86_64...  

Works out of the box on Raspbian Stretch on my RPi 3B.

Works out of the box on Armbian 5.6 (Xenial) on my Orange Pi+ 2E...

Qualification : avahi works on the Banana in that other hosts can reach it (e.g. "ping ffrwchnedd.local" works from any other machine) - so it's announcing itself on my LAN, but it cannot use avahi to reach other hosts by hostname.local (no problem pining actual IP address of other devices).

If I can't resolve this soon - I'll go back to Xenial and try and figure out how to do some version control on my ~/.ssh/config file(s) (I have a common one symlinked from my Resilio Sync folders).

P.S. I didn't upgrade in place - I just booted from a fresh flashed SD card so I can backout to Armbian 5.6 Xenial without too much pain (other than re-syncing 130 GB of Resilio Sync folders - stored on 256 GB USB drive).


Link to comment
Share on other sites

Update : it's not working on any of my Armbian machines...  doesn't work on Xenial Armbian 5.7 on bananapi, or Xenial Armbian 5.6 on orangepi+ 2E...  those machine names can be resolved from other hosts on the LAN, but they themselves are unable to resolve other machine names on my LAN.  I could have sworn it was working previouisly.


Close this topic - clearly not related to Armbian Bionic...  I have no idea what's going on...

Link to comment
Share on other sites

thanks for that info - the issue I have with Armbian, I can resolve the Armbian hosts on my LAN from other machines (all Linux), but from Armbian itself I can't resolve other host's names...  

Not 100% sure what "publish-workstation" does - but it kinda sounds like advertising itself on the LAN?  Anyway I reset that to "yes" on a Linux laptop (x86_64) and on Armbian, and it's the same as before...

I might try out stretch then...  avahi works out of the box for me on Raspbian Stretch...

Link to comment
Share on other sites

22 hours ago, devman said:

I had to change the entry in my /etc/nsswitch.conf to include "mdns4_minimal" in the "hosts: " line so it would resolve blahblah.local addresses


Already tried that - still won't resolve hostnames on my LAN (two different LANs - my home LAN and my work LAN)...  NSSWITCH usually one of the first places I look (hangover from Solaris)...

hosts:          files mdns4_minimal dns myhostname

Also - noticed some wildly different results from /sys/power/axp_pmu/battery/ output compared to Armbian Xenial on the same hardware...

I don't know if that's because Bionic is drawing more power and battery never gets to 100%...   but its always around 96% and always "discharging"

╰─➤  cat /sys/power/axp_pmu/battery/capacity
╰─➤  cat /sys/power/axp_pmu/battery/charging


Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines