Jump to content
  • 0

OPi PC+ not booting with 3G modem inserted


jupiter8
 Share

Question

Hello, i'M having this issue with the latest Armbian 5.75 stretch image with updated firmware.

 

When booting with a huwei E303 modem is in the usb port the board fall in a eternal reboot.

 

if i let the board boot as normal an then insert the modem everything is o.k. I tried with 4 others OPI PC+ and others E303 sticks, same thing.

 

also tried with 5.65, same problem.

 

BUT,  with an earlier version 5.35 and it boots as normal.

 

 

Edited by jupiter8
Link to comment
Share on other sites

15 answers to this question

Recommended Posts

  • 0
1 hour ago, jupiter8 said:

When booting with a huwei E303 modem is in the usb port the board fall in a eternal reboot.

Try to capture logs during boot process using a USB-TTL Serial dongle and provide us the errors that are responsible of such reboot...

 

Link to comment
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

  • 0
15 minutes ago, jupiter8 said:

Strange that it works with 5.35...

Maybe the old 5.35 didn't scan the USB ports to find Mass Storage.

If you don't need MS in U-Boot and still both from SDCard, maybe you can build your own custom U-Boot with USB disabled ...

Link to comment
Share on other sites

  • 0

Well, i never played with U-Boot is there some good tutorial you can recomand?

 

Also i presume we shall consider this a bug and it's not being adressed since 5.38 at least (just tried it on another OPI that ia had and it worked) 

and no one seems to experienced this based on a quick search.

 

Is anybody having a 3g dongle could duplicate this?

 

Thanks to all.

Link to comment
Share on other sites

  • 0
25 minutes ago, jupiter8 said:

Well, i never played with U-Boot is there some good tutorial you can recomand?

I'm not sure how are you ready to get your feet wet, but take a look at Armbian build process : https://docs.armbian.com/Developer-Guide_Build-Preparation/

 

25 minutes ago, jupiter8 said:

Also i presume we shall consider this a bug

Maybe, but not an Armbian bug, but a U-Boot bug ...

The fact that it is appear after 5.38 is simply because we have enabled the functionality for some people that are using USB dongle or USB HDD as booting devices.

The bug with your 3G dongle maybe exist since ever, but no one faced the issue until now ... Maybe some other kind of 3G dongle will work, I don't know ...

 

Link to comment
Share on other sites

  • 0

Unfortunately i don't have time to get those feet any wetter than this... :(

The only way to get out of this is to roll back, i'll try the 5.30 image from the archives.

 

 

I tried the raspian image for OPI and it works, should i stay with that or Jessy 5.30?

 

My use of this SBC is only to get values from a PLC via Node-red and sent to MQTT if it works it will stay as is without updates as nothing will change in this setup.

 

Thanks for helping Martin.

Link to comment
Share on other sites

  • 0
1 hour ago, jupiter8 said:

I tried the raspian image for OPI and it works, should i stay with that or Jessy 5.30?

( raspian != Armbian ;) )

Yes, you can stay on Jessy 5.30, but you can also backup u-Boot from this 5.30, keep it aside, and overwrite the U-Boot on your recent image, you will then have both benefit ...

Link to comment
Share on other sites

  • 0
8 hours ago, jupiter8 said:

May i ask for a little guidance on this?

First, boot you Jessie 5.30 to do a u-boot backup :

dd if=/dev/mmcblk0 of=uboot-backup.img bs=1024 skip=8 count=750

Then, copy this uboot-backup.img elsewhere, over network for example.

Halt the OPiPC, and then exchange the SDCard to boot latest Armbian.

Restore the uboot-backup.img by overwriting the current one :

dd if=uboot-backup.img of=/dev/mmcblk0 bs=1024 seek=8

Then, reboot ... You will see that u-boot is the old one but image itself is the new one ...

Retest the boot phase with you 3G dongle plugged in ...

 

Link to comment
Share on other sites

  • 0

Sadly this doesn't work for me it falls into an eternal boot again without anything plugged in. tried with 5.30's U-Boot and latest armbian fresh install, changed password, made user pi, no updates, saved U-boot, swapped OS, same thing, changed pw, made user pi and put back U-Boot, tried with 2 differents OPI an PSU. 

 

 

Link to comment
Share on other sites

  • 0
34 minutes ago, jupiter8 said:

Sadly this doesn't work for me it falls into an eternal boot again without anything plugged in.

I don't understand : you were saying that 5.30 u-boot was working properly with the 3G plugged, and now you are talking about eternal boot without anything plugged !

So, maybe the issue is your board itself, starting to get into hardware troubles ...

Link to comment
Share on other sites

  • 0

O.K. , after further investigations it seems that commenting out the line with "auto" in "/etc/network interfaces" cure the problem as at boot,  the O.S.  won't try to do whatever with the device i named "gprs" (my usb cell dongle)

 

#auto gprs
allow-hotplug gprs
iface gprs inet ppp
provider gprs

 

Now everything is good.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...