Wizzard

Members
  • Content Count

    18
  • Joined

  • Last visited

About Wizzard

  • Rank
    Member

Profile Information

  • Gender
    Male
  • Location
    Bratislava

Recent Profile Visitors

188 profile views
  1. I wonder if there is some Armbian/another distro for RK3066A based chipset. I heard something about Picuntu, but seems that the download links are no longer working and it is based on some outdated Ubuntu distro. Any idea what else can I find for this device?
  2. Resolution: to add this line to /boot/armbianEnv.txt extraargs="video=1280x720@60"
  3. Please, does the latest Armbian support setting the resolution on boot? I want to use this resolution in my SDL2 based app, so things like randr does not help me. Thank you very much.
  4. Hello, I am trying to use BPI with legacy Armbian and Stella emulator with 16:10 monitor (using HDMI-DVI cable) I just dont know how to set proper 16:10 resolution. The resolution I set in armbian-config is 1680x1050, but it is different from resolution that Stella uses, when I launch it on the startup. It uses the resolution defined in FEX. So I checked https://linux-sunxi.org/Fex_Guide#disp_init_configuration and tried various resolutions, but dont know which of them is 16:10 and what is the exact resolution. For example 576p can mean anything. How can I find it out?
  5. I think Armbian only supports TV out in legacy kernel. I am using BPI M1 with legacy Armbian and it works fine. I use it as a retro gaming console, so it is fine for me. I have just a problem that the picture overscans the monitor and seems to me impossible to fix it.
  6. I just tried it on my x86 PC with Ubuntu Focal with 5.4.0 kernel. Modprobe xpad works, joystick seem to be detected in Stella and Retroarch, just does not work, cannot map any key and it does nothing. Seems like some kernel issue cause it only worked in on legacy kernel 3.4.x. Just made another quick search and it is problem very similar to this: https://github.com/paroj/xpad/issues/83 although the device is different, it has the same id 045e:028e So it may not be Armbian problem, but general Linux problem, although I still do not know what to do. It is just the
  7. I would just expect that many people use SBCs for gaming with Retropie and similar software, mostly RPI, but sunxi devices are interesting for me because of their price.
  8. Some time ago I tried that joystick on Pinebook Pro and it did not work either, I think the same problem was with x86 PC in Linux, but have to check it again.
  9. Thank you very much. I was not sure where to ask for help, did not know if it is Armbian specific bug or general Linux kernel issue.
  10. Thank you very much. I tried BPI image, xpad is present, it detects joystick, but still does not do any actions. Another joystick works, xbox compatible joystick not. Very interesting for me. http://ix.io/2uQkery
  11. Thank you very much, I will try it, but would it be possible to create also some test build for Banana Pi M1? It is easier for me to test it on this board now. Thank you very much!
  12. Wizzard

    Wizzard

  13. Hello, friends. I am using legacy Armbian 3.x kernel on my development boards where I run Stella emulator with some special USB joystick. The joystick is detected as XBOX controller, hence I guess it uses xpad driver. The problem is that this driver is not present in the latest Armbian so this joystick does not work. I would like to use latest Armbian to have the latest packages, using it as a print/scan/radio server and would like also to play some Atari game from time to time. I tried to build it from the source using this https://github.com/paroj/xpad I can load it with modprobe,
  14. It is funny that just today I am experiencing a problem with upgrade: Processing triggers for initramfs-tools (0.133ubuntu13) ... update-initramfs: Generating /boot/initrd.img-4.4.210-rockchip64 E: /usr/share/initramfs-tools/hooks/btrfs failed with return 1. update-initramfs: failed for /boot/initrd.img-4.4.210-rockchip64 with Maybe anyone could point me to the solution? I tried removing btrfs package, but the it is still the same. I tried removing the 64-bit kernel package and installed non-64 bit package but it obviously does not boot ed
  15. I must say I am very satisfied with Armbian. Using it as my primary OS now. Just the graphics acceleration is not perfect yet (Retroarch, PP Racer etc.), but it is really usable. Keep on good work!