0
SecureXperts

GPIO Hat not detected over the IIC interface SCL, SDA

Recommended Posts

I have the following hat http://wiki.seeedstudio.com/Raspberry_Pi_Relay_Board_v1.0 my image detects the i2c interfaces and mounts them in /dev as i2c-0  i2c-1  i2c-3  i2c-4, 

I can scan the different i2c interfaces as folloging interface

i2cdetect -y 1 

root@rockpi:~# i2cdetect -y 1
     0  1  2  3  4  5  6  7  8  9  a  b  c  d  e  f
00:          -- -- -- -- -- -- -- -- -- -- -- -- --
10: UU 11 -- -- -- -- -- -- -- -- -- -- -- -- -- --
20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
60: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
70: -- -- -- -- -- -- -- --
 

I have set 0x20 address on my relay Board but cannot see the interface. 

 

Has anyone a hint what configuration settings i need to change

 

Many Thanks

 

Roman

Share this post


Link to post
Share on other sites
2 minutes ago, pavelectric said:

So check on the other bus ...

root@rockpi:~# i2cdetect -y 2

Hi pavelectric

The /dev/i2c-2 is not available on my Image. Do in need to load some Kernel modules for that?

Thanks

Share this post


Link to post
Share on other sites
31 minutes ago, SecureXperts said:

my image detects the i2c interfaces

The I2C present on Header pins 3 and 5 is the I2C7.

To get I2C7 appearing as /dev/i2c-7, it requires to load the rockchip-i2c7.dtbo overlay which is present in /boot/dtb/rockchip/overlay.

To do that, add the "overlays=i2c-7" into the /boot/armbianEnv.txt and reboot.

Share this post


Link to post
Share on other sites
10 hours ago, martinayotte said:

The I2C present on Header pins 3 and 5 is the I2C7.

To get I2C7 appearing as /dev/i2c-7, it requires to load the rockchip-i2c7.dtbo overlay which is present in /boot/dtb/rockchip/overlay.

To do that, add the "overlays=i2c-7" into the /boot/armbianEnv.txt and reboot.

Hi martinayotte, 

thanks a lot for your input. Indeed i2c7 was not loaded. ;-) To add this overlay the good command is overlays=i2c7 without dash.

Now all my HATs communicating over this bus is working like a charm!

Share this post


Link to post
Share on other sites
0