Tinker Board S


1 1

Recommended Posts

Hi all,

I just bought TinkerBoard S and I downloaded 

Armbian Stretch 4.19 (tried both with and without desktop ) and I tried to boot.

But no luck I was waiting for few mins but nothing.

I also tried Armbian Strech 4.4 but also nothing.

Am I missing something here?

Original TinkerOS work without any issue


Thank you for any advice/help



Link to post
Share on other sites

Donate and support the project!


I wanted to test the latest version of armbian for tinkerboard (Armbian_19.11.3_Tinkerboard_bionic_legacy_4.4.199_desktop)

Unfortunately this version does not work and not start. The green led remains off.

I try with different sd micro card of different brand and I check the key SHA.

With my old version no start problem  (Armbian_5.95_Tinkerboard_Ubuntu_bionic_default_4.4.190_desktop).


in addition the previous images were deleted


thank for help!

Link to post
Share on other sites

I can confirm that the latest images for Thinker Board do not boot on a Tinker Board S / eMMC.

I do not own a Tinker Board (no S) and did not try booting from a SD-card.


The message "Begin: Running /scripts/local-block ... done." is shown repeatedly.

I have already checked that the UUID in /boot/armbianEnv.txt /etc/fstab are equal to the actual partition UUID.

I also noticed that "usbstoragequirks=..." has been removed from /boot/armbianEnv.txt, but adding it didn't help.


The following images DO NOT boot:

- Armbian_19.11.3_Tinkerboard_buster_current_5.3.11_minimal.img

- Armbian_19.11.3_Tinkerboard_buster_legacy_4.4.199_desktop.img

- Armbian_19.11.3_Tinkerboard_buster_legacy_4.4.199.img


The following images DO boot properly:

- Armbian_5.95_Tinkerboard_Debian_buster_default_4.4.190.img

- 20190821-tinker-board-linaro-stretch-alip-v2.0.11.img



Link to post
Share on other sites

I've just bought two Tinkerboards S for my thesis project, and I need to install Armbian on it.

I've accustomed myself with the maskrom mode and I've successfully booted the Debian TinkerOS from both the SD and the eMMC.

Similarly I successfully booted Armbian from the SD but once I flash the same image on the eMMC it fails to boot, I get this output:

Scanning for Btrfs filesystems
Gave up waiting for root device.
Common problems:
- Boot args (cat /proc/cmdline)
- Check rootdelay= (did the system wait for the right device?)
- Check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT! UUID=a5ccaf22-ffde-44c2-8c59-84a851f9fd90 does not exist. Dropping to shell!

I've checked and /boot/armbianEnv.txt and /etc/fstab match the uuid obtained with


corresponding to /dev/mmcblk1p1 (the root partition on the eMMC)


I've been flashing images like this for both the SD card (plugging it in the PC) and the eMMC using the microUSB cable connected to the tinkerboard:

dd if=armbian_image.img of=/dev/sdX bs=4M status=progress oflag=sync

I've tested these different images with same results, also building one did not change the results.

  • Armbian_19.11.3_Tinkerboard_bionic_current_5.3.11/

  • Armbian_19.11.3_Tinkerboard_bionic_legacy_4.4.199_desktop/

  • Armbian_19.11.3_Tinkerboard_buster_current_5.3.11_minimal/


I can't find a good guide for this, I suspect it could be related to UBoot.

Seems like it can't read the root partition somehow, do you guys have any idea?

Edited by kknickkk
forgot the S
Link to post
Share on other sites

@kknickkk: you can find the older builds on the download page under the "old" link; I used 5.95 and apt-get upgraded to the latest version.


edit: also useful to read/know that it does boot from SD, just not from eMMC.


@igor: good to see that this issue is being worked on. Let me know if I can do some testing.

Link to post
Share on other sites

7 minutes ago, Sander de Leeuw said:

good to see that this issue is being worked on

Nobody is working on since Armbian does not have any crew/budget for such troubles. I have put it to the Jira to take a look once I am back to tho office ... if it will not be solved by someone else in the mean time. Currently 20.000 km away. 

Link to post
Share on other sites

Hi, thanks for the reply


I've noticed after some work that older versions work and now I've settled with the 4.19.33.


Is there any way I can contribute? Once I'm done with this project I'd be happy to help, your efforts on Armbian are deeply appreciated.

Link to post
Share on other sites

Motivated by Igor's "no crew" argument, I gave it a shot myself, but without much success yet.


I have removed "panic=10" from /boot/boot.cmd and ran mkimage.

This allowed me to enter the busybox shell from u-boot.


$ cat /proc/partitions

1 0 4096 ram0


So the eMMC modules does not seem to be recognized by the kernel.

When I plugin a SD-card, it's immediately detected and available for use.




It seems to me that eMMC support is not (completely) functional in the kernel.

Checked the kernel configuration files, but in both versions, MMC/eMMC support is enabled:


[sander@thinkpad-t480 Work]$ grep EMMC config-4.4.190-rockchip
[sander@thinkpad-t480 Work]$ grep EMMC config-5.3.11-rockchip
[sander@thinkpad-t480 Work]$ grep MMC= config-4.4.190-rockchip
[sander@thinkpad-t480 Work]$ grep MMC= config-5.3.11-rockchip

I noticed a bunch of new kernel modules (configured as modules) in the u-boot initrd of 5.3.11-rockchip.

Tried to load them, but that didn't change a thing. For reference, here's a list of modules I tried/loaded:



 * core/pwrseq_sd8787.ko,

 * host/dw_mmc-bluefield.ko,

 * host/rtsx_usb_sdmmc.ko,

 * host/sdhci-cadence.ko,

 * host/sdhci-of-dwcmshc.ko




Also compared the init and other scripts under /scripts in the u-boot initramfs between Armbian_5.95 (ok) and Armbian_19.11.3 (not booting).

Did not find a significant difference there.


So far no good ;-) Will give it another try later on.

Link to post
Share on other sites

17 hours ago, kknickkk said:

Is there any way I can contribute? Once I'm done with this project I'd be happy to help, your efforts on Armbian are deeply appreciated.

It depends on your know-how, time, desire, ... there are many things what can be done. We all tend to look away on maintenance tasks. Things which are on a long run and nobody notice that someone has to take care. Helping on maintaining any of https://github.com/armbian repositories content. From low level, bash scripting (armbian-config) all the way to (general) docs. They all need constant updating.

Link to post
Share on other sites

This topic is now closed to further replies.

1 1