0
LogicalUnit

SMB shares not working after update

Recommended Posts

Hi everyone,

I have a Helios4 NAS on which I have installed Armbian 5.85. I used the Armbian-Config to install OMV 4.1.23-1 (Arrakis). I used OMV to configure some CMB/CIFS shares which were working properly.

I connected to my server via SSH, and performed an apt update/upgrade, and I think this broke my SMB shares. According to my Googling, Debian now uses smbd instead of samba. When I try to access my shares at \\192.168.1.x I get a message that says "The specified network name is no longer available." When I run sudo service smbd status, I get the following:

● smbd.service - Samba SMB Daemon
Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
Active: active (running) since Thu 2019-07-04 12:03:24 UTC; 6min ago
Docs: man:smbd(8)
man:samba(7)
man:smb.conf(5)
Main PID: 2602 (smbd)
Status: "smbd: ready to serve connections..."
Tasks: 3 (limit: 4915)
CGroup: /system.slice/smbd.service
├─2602 /usr/sbin/smbd
├─2603 /usr/sbin/smbd
└─2604 /usr/sbin/smbd

Jul 04 12:03:24 helios4 systemd[1]: Starting Samba SMB Daemon...
Jul 04 12:03:24 helios4 systemd[1]: smbd.service: Supervising process 2602 which is not our child. We'll most likely not notice when it exits.
Jul 04 12:03:24 helios4 smbd[2602]: [2019/07/04 12:03:24.781392, 0] ../lib/util/become_daemon.c:124(daemon_ready)
Jul 04 12:03:24 helios4 systemd[1]: Started Samba SMB Daemon.
Jul 04 12:03:24 helios4 smbd[2602]: STATUS=daemon 'smbd' finished starting up and ready to serve connections

When I run sudo service samba status I get

 

● samba.service
   Loaded: masked (/dev/null; bad)
   Active: inactive (dead)

My /etc/samba/smb.conf file is attached (remove .txt extension)

Any help appreciated.

Thanks,
~LU

smb.conf.txt

Share this post


Link to post
Share on other sites

it looks like smbd is searching the smb.conf not every time in /etc/samba but maybe in 

/usr/local/samba/lib/

 

This is the default location of the smb.conf(5) server configuration file. Other common places that systems install this file are /usr/samba/lib/smb.conf and /etc/samba/smb.conf.

 

https://www.samba.org/samba/docs/current/man-html/smbd.8.html

 

(EDIT)

your smb.conf seems to be a empty default one, because the shares media and main have - for me - no real useable path.

do you got a backup of your old smb.conf?

sometimes - while updating - apt does ask to replace some files and if you did say yes to replace then its possible that apt did replace you smb.conf :(

Share this post


Link to post
Share on other sites

Okay so I believe that the smb.conf file I attached is what is created by the Open Media Vault web interface. I configured the shares "main" and "media" and their paths in the file are correct. I think the problem is that OMV wants to use samba, but since I upgraded Armbian from the command line, samba has been disabled in favour of smbd.

 

So it's possible that smbd is looking for smb.conf in the wrong place. The one I attached came from /etc/samba/smb.conf

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0