Jump to content

ERROR in function download_and_verify [ general.sh:995 ]


Recommended Posts

Trying to setup a build environment using vagrant, keep getting the following error. I've deleted everything and started over several times but keep getting stuck here. Any ideas what I'm doing wrong?


vagrant@ubuntu-bionic:/vagrant$ sudo ./compile.sh 

[ o.k. ] Using config file [ /vagrant/userpatches/config-example.conf ]

[ o.k. ] Preparing [ host ]

[ o.k. ] Build host OS release [ bionic ]

[ o.k. ] Syncing clock [ host ]

[ o.k. ] Checking for external GCC compilers 

[ .... ] downloading using torrent network [ gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz ]

[ error ] ERROR in function download_and_verify [ general.sh:995 ]                                                                                   

[ error ] verification failed 

[ o.k. ] Process terminated 

Link to comment
Share on other sites

I'm not sure exactly how you got to the point of this failure,  which I think is some kind of "key" problem,  but to test,  I just deleted my armbian-builder box, and the  build directory,


recloned the build directory .i.e.


git clone --depth 1 https://github.com/armbian/build


cd 'd  into build i.e.


cd build


and ran ./compile.sh vagrant


This worked; it created the box and downloaded all the compilers properly...


It seems that the "new" compile.sh from about three weeks ago  actually does a lot more for one than the old methodolgy.  (I believe it will even install vagrant and virtualbox if they are not there)   You will be given the option to halt the box when your particular compile is finished.   I think you can then get back into it by issuing the 

vagrant up

vagrant ssh



command s from the /build/userpatches directory.  


I'd be happy to change the doc to match what is actually going on if I understood whether I have a correct understanding of things, myself. :-)

Link to comment
Share on other sites

Thanks @belfastraven for testing! I wasn't aware of using the "vagrant" switch, I was setting up vagrant manually following these instructions. https://docs.armbian.com/Developer-Guide_Using-Vagrant/


I still must be missing something though, I tried repeating your steps and received this. I'm using macOS (Catalina), I'm assuming this method is meant to be done on linux side?


| => sudo ./compile.sh vagrant

./compile.sh: line 16: realpath: command not found

./compile.sh: line 77: systemd-detect-virt: command not found

./compile.sh: line 180: realpath: command not found

[\e[0;32m .... ] Config file does not exist [\e[0;33m userpatches/config-vagrant.conf ]



Link to comment
Share on other sites

4 hours ago, djjerdog said:

I'm using macOS


Automatic install only works on Debian based systems. Here you have to install Vagrant or Docker manually. And this new install was not tested on MacOS so I have no idea ... someone with Mac should check this. Bugs are possible.

Link to comment
Share on other sites

4 hours ago, Raylynn Knight said:

Perhaps the documentation should be update to prevent hours of frustration


Still waiting for a MAC/Vagrant user that would write what shell be done and send a pull request to the documentation. 

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines