Problem configuring CUPS


 Share

1 1

Recommended Posts

Not sure if this is considered an appropriate request for the Armbian forum, but I'll give it a try. New installation of Buster server 4.19.62-sunxi on OPiZero 512MB, with 32GB SanDisk A1 card. 

I installed CUPS (and Samba) via armbian-config, added myself to lpadmin; I can access the web interface. "Add printer" sees my Brother HL-2270DW on wifi, but no matter how I add the printer, I get one of a variety of errors when attempting to print a test page.

CUPS finds and installs the printer at dnssd://Brother%20HL-2270DW%20series._ipp._tcp.local/ but when I print a test page, CUPS says it can't find the printer. So I change the URI to the printer's IP address on my LAN. CUPS now says printer is "Idle, Accepting Jobs, Not Shared".  When I print a test page, CUPS says "processing since" and keeps saying it forever (until I cancel the job). Same thing happens if I install as IPP printer, same thing with hl1250 driver or generic pcl driver. Same thing with or without foomatic. I can't find any guides about how to troubleshoot CUPS if it doesn't just work, so I'm likely doing something wrong, though I also see comments online from people who get stuck at "processing since," saying that they had to downgrade something or other because of incompatible packages. Appreciate any tips, including if anyone knows about a CUPS troubleshooting forum out there.

armbianmonitor -u http://ix.io/23JA

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

10 hours ago, usual user said:

First step would be to enable "Save debugging information for troubleshooting" in the administration tab and inspect the log files.

Thanks; I've done that, but the error log is miles long and I don't know what to look for or how to interpret it. I'm brand new to CUPS, and pretty beginner on linux in general; I can figure out some things when I find a decent how-to guide, but I haven't been able to find one that covers troubleshooting CUPS printer installation. My problem is quite likely user error, and not something armbian-specific; if anyone might suggest an appropriate forum site I'd be happy to ask for help there. 

Link to post
Share on other sites

As can be seen from the log (Executing backend \"/usr/lib/cups/backend/dnssd\"...) the cups backend is been started over and over again without succeeding in transfer any data to the printer.
Maybe e.g. some firewall rules or something else network related is not setup properly. To approve this, connect the printer via USB and check if printing is working then.

Link to post
Share on other sites

On 12/8/2019 at 3:53 AM, usual user said:

As can be seen from the log (Executing backend \"/usr/lib/cups/backend/dnssd\"...) the cups backend is been started over and over again without succeeding in transfer any data to the printer.
Maybe e.g. some firewall rules or something else network related is not setup properly. To approve this, connect the printer via USB and check if printing is working then.

Yep, just tried it on the OPi's usb connection, and it worked first time. 

 

I don't see anything on my router that would be blocking communication between CUPS and the printer over the wireless network (I do have upnp disabled, but I don't think that should matter).  I haven't (knowingly!) done anything on the OPi that would block network communication. And, curiously, when I was attempting to configure over wifi, CUPS *was* able to detect the printer during setup. I'm at a loss. There aren't some other packages that I'm supposed to install to enable wireless CUPS printing, are there?

Link to post
Share on other sites

22 hours ago, mc510 said:

Yep, just tried it on the OPi's usb connection, and it worked first time. 

Now you know you have a proper working CUPS.

22 hours ago, mc510 said:

I don't see anything on my router that would be blocking communication

As hubs, switches or bridges usually do not apply any firewall rules if the devices are in the same network segment, there is nothing you should blame your router for.

22 hours ago, mc510 said:

I haven't (knowingly!) done anything on the OPi that would block network communication.

Having *no* print spool service on a device is quite common and rightfully a firewall does not open any ports for any specific print communication by default.

22 hours ago, mc510 said:

CUPS *was* able to detect the printer during setup.

Service discovery has primary nothing to do with print protocols. It is e.g. done by zero-conf (avahi) using different ports. And as it is being used by several services it is quite common a firewall has the involved ports open by default.

 

To check if the firewall on the OPi is the culprit, temporary disable it entirely and try printing via network again.

Link to post
Share on other sites

9 hours ago, usual user said:

To check if the firewall on the OPi is the culprit, temporary disable it entirely and try printing via network again.

Oh jeez; I am so far out of my depth here.  I did not even know that Armbian has a firewall/rules enabled by default 🤦‍♂️. I should just put this CUPS issue aside until I have learned more about administering an armbian/debian system.  Thanks for the time and help that you've given me.

Link to post
Share on other sites

On 12/7/2019 at 1:08 AM, mc510 said:

sees my Brother HL-2270DW on wifi, but no matter how I add the printer, I get one of a variety of errors when attempting to print a test page.

Troubleshooting,

  1. USB (cable) works :D
  2. Ethernet cable (your printer has one, right?)  :unsure:
  3. WiFi, but WiFi on OPiZero is tricky, see below.  :blink:

Once No. 2 works your network is not blocking it -  get this sorted out. Do not start with WiFi until that works.

If you are using the 'onboard' WiFi of your OPiZero,  then try to disable that. Take an USB-WiFi-Stick (borrow one from a friend) test it with this first, because onboard WiFi-Driver is nowhere stable:   https://forum.armbian.com/topic/12403-opi-zero-xr819-wifi-broken-in-new-builds/

 

Last but not least, please report back :)

Link to post
Share on other sites

11 hours ago, Tido said:
  1. USB (cable) works :D
  2. Ethernet cable (your printer has one, right?)  :unsure:
  3. WiFi, but WiFi on OPiZero is tricky, see below.  :blink:

Once No. 2 works your network is not blocking it -  get this sorted out. Do not start with WiFi until that works.

I described my connection poorly; I'm actually not using the wifi on the OPi. It has an ethernet connection to my router, and the router connects to the printer over wifi. So as far as the OPi is concerned, it's an ethernet connection.

 

Anyhoo! Yes, printing over USB works :D. I can't readily connect the OPi directly to the printer via ethernet, since OPi's ethernet is how it connects to the local network. But I did try connecting the printer to the router on ethernet (rather than wifi), and it works :D. And then when I took the printer off ethernet and back on wifi, leaving CUPS with the same configuration, it continues to work :D:blink:! Only thing I can see that might be different is that, when connected on ethernet, I had CUPS use LPD instead of DNSSD. Don't remember if I had tried that previously. Even at that, I still had to manually edit /etc/cups/printers.conf to to put the printer's static IP in the device URI, in place of the "friendly" name that CUPS had selected. So this whole thing is probably 100% user error/inexperience. Thank you @Tido @usual user @martinayotte so much for your help and your patience with me!

Link to post
Share on other sites

OK, now that you described your network topology in more detail it is obvious what is going on.
Your router does not connect the WiFi and Ethernet segment in bridged mode but handles them as two separate segments where routing takes place and firewall rules get applied. Ports for service discovery (mdns) and LPR (printer) seem to be enabled already but for ipp-everywere or aiprint (ipp) are not.
With all properly setup and cups-browsed from the cups-filters package running there should be no user intervention be required to add the printer. cups-browsed will discover it, setup a suitable queue and in applications it will show up as printer to use.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

1 1