Jump to content
  • 0

mpg123-audio via HDMI much too fast on OPi One


guidol
 Share

Question

Armbianmonitor:

today I compiled a image for my OPi One:
 

Armbian Buster with Linux 5.4.2-sunxi
package bsp-kernel[19.11.3.342] u-boot[19.11.3] dtb[19.11.3.342] 
firmware[19.11.3] config[19.11.3]
branch[dev]

but mpg123 is playing a 128kb/s Radio-Stream much too fast via HDMI (hw:0,0) -

streaming the same URL via a USB-Audio-Dongle (hw:1,0) has the right speed :(

 

Spoiler

root@opi-one(192.168.6.114):/toshiba/iradio/stations# more  ./MP3_SAW_80s
http://saw-de-hz-fal-stream10-cluster01.radiohost.de/saw-80er_128

 

root@opi-one(192.168.6.114):/toshiba/iradio/stations# mpg123 -v -b 2048 -a hw:1,0 -@ ./MP3_SAW_80s
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
        version 1.25.10; written and copyright by Michael Hipp and others
        free software (LGPL) without any warranty but with best wishes
Decoder: generic
Trying output module: alsa, device: hw:1,0
Using playlist from ./MP3_SAW_80s ...
Note: guessed M3U playlist type

Directory: http://saw-de-hz-fal-stream10-cluster01.radiohost.de/

Terminal control enabled, press 'h' for listing of keys and functions.

Playing MPEG stream 1 of 1: saw-80er_128 ...
ICY-NAME: 80er
ICY-URL: http://stream.saw-musikwelt.de/saw-80er

MPEG 1.0 L III cbr128 44100 j-s
> 24+01  00:00.62+00:00.00 --- 100=100 128 kb/s  418 B acc    0 clip p+0.000
ICY-META: StreamTitle='BILLY IDOL - REBEL YELL';
> 1091+0001  00:28.49+00:00.00 --- 100=100 128 kb/s  418 B acc    0 clip p+0.000
[0:28] Decoding of saw-80er_128 finished.

 

Display output (from the numbers) is the same, but with HDMI the buffers gets empty too fast because of the wrong speed...

Does have anybody also this issue?

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

Armbian Linux community supported weekly builds download

  • 0

Problem solved!

 

The dtb file is wrong on newer Kernels after 5.3.9

There is an added option called dai-tdm-slot-width (description) in the sound category which is set to high (0x20). When you set this to 0x10 (decimal 16, I think 16Bit for audio!?) the Sound is in normal speed.

There is another typo, I think, in line 897 phy-names is set to "phy" but the name of the phy is "hdmi-phy" so its in old dtb's too.

Corrected dts for Orange Pi PC in attachment.

Please test this on other boards...

EDIT: Confirmed on sunvell R69 1.3 with Kernel 5.5.0cr2

 

Regards

devicetree-5.4.8.dts

Link to comment
Share on other sites

  • 0

@nylonatathep Thanks for the solution ;) 
I can confirm it also for the Orange Pi One

 

DTB to DTS:
dtc -I dtb -O dts /boot/dtb/sun8i-h3-orangepi-one.dtb -o /boot/dtb/sun8i-h3-orangepi-one.dts

DTS to DTB:
dtc -I dts -O dtb /boot/dtb/sun8i-h3-orangepi-one.dts -o /boot/dtb/sun8i-h3-orangepi-one.dtb

Kernel:
Linux opi-one 5.5.0-rc2-sunxi #19.11.5 SMP Tue Dec 31 13:30:06 +03 2019 armv7l GNU/Linux

PS: as usual - the corrected .dtb gets lost via a apt upgrade if you doesnt set it on hold :(

apt-mark hold linux-dtb-dev-sunxi

 

sun8i-h3-orangepi-one.dtb sun8i-h3-orangepi-one.dts

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...