RDP failing after cold reboot


2 2

Recommended Posts

Hi there,


First of all, have a nice christmas. Especially you Igor, im still amazed by what armbian is.


I'd like to ask a question regarding a problem i'm having. Last two days i've been setting up my rockpi 4 as a replacement server. I had everything configured correctly and working. I left the rock on over night and discovered this morning that i couldn' t connect over SSH and vnc/rdp anymore. Since i couldn't connect and the rock was headless i pulled the power an forced a reboot.


After the reboot i could connect to ssh but not over rdp or vnc. My app jump desktop gives the following error: Could not create SSH tunnel. Please make sure tcp forwarding is enabled on the server. Details: Chanel open failure (connection failed).

The weird thing is, i have not changed anything since the last time, it just doesn't work anymore now so i dont know where to look to solve the issue.


I have the following settings:

address: (port is forwared in the router and open in ufw)

ssh tunnel: username@ip_address with private key (also tried username@local ip with key. no effect)

(ssh is working so the keys or the adresses should not be the problem, tried the exact same keys and both ip as local ip for ssh)


My sshd_config file is in the attatchment. note that i have set allowtcp forwarding to 'yes' as was requested in the error log of jump desktop.


I've also tried re-enabling rdp in armbian-config no effect

I've also tried running vncserver mp effect


I've hooked up the system to a monitor and it just normally boots to desktop as expected.


Does anyone have some tips where i should start looking for this problem ? I have a hard time doing this since it happened without me interfering.


Thank you in advance.


Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Edit: Nevermind the unknown state seems to be normal....


I think there is something wrong with my local host, it’s states as unknown:


ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 0e:24:d9:ea:96:09 brd ff:ff:ff:ff:ff:ff
    inet brd scope global noprefixroute eth0
       valid_lft forever preferred_lft forever
    inet6 2001:980:cd62:1:cc7d:c076:afd7:4863/64 scope global temporary dynamic 
       valid_lft 3723sec preferred_lft 3226sec
    inet6 2001:980:cd62:1:adbf:9afd:ce2e:f8bd/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 3723sec preferred_lft 3226sec
    inet6 fe80::3935:53f9:bb77:cddc/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 6c:21:a2:37:91:7e brd ff:ff:ff:ff:ff:ff


Should that be a source of the problem ?

Link to post
Share on other sites

Ive been doing some digging and it seems that the xRDP service is failed after a reboot:

sudo systemctl status xrdp.service 
● xrdp.service - xrdp daemon 
Loaded: loaded (/lib/systemd/system/xrdp.service; enabled; vendor preset: enabled) 
Active: failed (Result: exit-code) since Thu 2020-01-02 19:13:28 CET; 44s ago 
Docs: man:xrdp(8) 
Process: 4517 ExecStart=/usr/sbin/xrdp $XRDP_OPTIONS (code=exited, status=1/FAILURE) 
Process: 4509 ExecStartPre=/bin/sh /usr/share/xrdp/socksetup (code=exited, status=0/SUCCESS)

Jan 02 19:13:28 rock systemd[1]: Starting xrdp daemon... 
Jan 02 19:13:28 rock systemd[1]: xrdp.service: Control process exited, code=exited status=1 
Jan 02 19:13:28 rock systemd[1]: xrdp.service: Failed with result 'exit-code'. 
Jan 02 19:13:28 rock systemd[1]: Failed to start xrdp daemon.

Some googling around revealed that this could be a recent bug in xRDP, more people have been reporting the behavior in the past months:

Got xrdp


Starting xrdp yields the following output, even after stopping the service first:

sudo systemctl start xrdp.service
Job for xrdp.service failed because the control process exited with error code.
See "systemctl status xrdp.service" and "journalctl -xe" for details.

Journal to log has no info from xrdp, just some login fail from OpenVPN i need to fix.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


2 2