Jump to content
  • 0

Mali / Lima Driver on Orange Pi +2e missing? 5.4.8 iamge


DevShanky
 Share

Question

Armbianmonitor:

I installed the latest 5.4.8 Buster Desktop image on my Orange Pi +2e board but find the Mali drivers are (Utgard) missing or not loaded. I have tried to follow every possible links including (https://linux-sunxi.org/Mali_binary_driver) related to get VDPAU / VAAPI and GPU but with very little success. I want to have HW acceleration enabled for playing MPEG in full screen mode 1920x1280 resolution using mpv. The frame drops are significant. 

 

Questions: Are Mali drivers  included in this build? If it is then how can I go about adding those drivers.

 

Is there any licencing issues in adding Mali drivers to the Armbian image? Is there any chances of Lima drivers being included in future releases?

 

There are Mali drivers available on ARM developer site that provides GPU Kernel Device drivers. Can I use them to build the custom Armbian image?

 

Appreciate any help in this matter.

 

Thanks

Rajesh

 

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

A quick look at Armbian monitor output revealed that Lima is actually installed.

 

Here is an output for 'sudo modinfo lima'

root@orangepiplus2e:~# sudo modinfo lima
filename:       /lib/modules/5.4.8-sunxi/kernel/drivers/gpu/drm/lima/lima.ko
license:        GPL v2
description:    Lima DRM Driver
author:         Lima Project Developers
alias:          of:N*T*Carm,mali-450C*
alias:          of:N*T*Carm,mali-450
alias:          of:N*T*Carm,mali-400C*
alias:          of:N*T*Carm,mali-400
depends:        gpu-sched
intree:         Y
name:           lima
vermagic:       5.4.8-sunxi SMP mod_unload ARMv7 thumb2 p2v8
parm:           sched_timeout_ms:task run timeout in ms (int)

 

How can I setup lima driver to VDPAU? I tried export VDPAU_DRIVER=lima.  It looks like I am missing something.

 

Thanks

Rajesh

 

Link to comment
Share on other sites

Donate and support the project!

  • 0
3 minutes ago, Rajesh said:

How can I setup lima driver to VDPAU? I tried export VDPAU_DRIVER=lima.  It looks like I am missing something.

Yes, you are missing something. Lima doesn't support video decoding. What you need is Cedrus. But using it is another story (currently a mess).

Link to comment
Share on other sites

  • 0
2 hours ago, Rajesh said:

Is there any licencing issues in adding Mali drivers to the Armbian image?


Its a "minor" issue. Sort this out
https://github.com/armbian/build/pull/1409

and Mali with binary blobs will be present in Armbian images.

The issue is - you are expecting services worth millions of dollars from amateurs.

 

2 hours ago, Rajesh said:

There are Mali drivers available on ARM developer site that provides GPU Kernel Device drivers. Can I use them to build the custom Armbian image?


You can build anything to the Armbian if you know what you are doing.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...