Jump to content

Cubietruck USB issue with HDD hub


Recommended Posts

Hi guys,

 

maybe you can give an advice. I have setup a NAS with my cubietruck, works like a charm with a single HDD3.5 sata connected.

I have an usb hub for two HDD 3., this one:

 

https://www.amazon.it/SALCAR-Docking-ottimizzato-compreso-Aluminum/dp/B01LZFH7NO/ref=sr_1_6?__mk_it_IT=%C3%85M%C3%85%C5%BD%C3%95%C3%91&dchild=1&keywords=salcar&qid=1588877559&sr=8-6

 

it's a 3.0 usb with external power, it works perfectly on my desktop pc: I can see both the disk, but nothing if connected to cubietruck USB port. It is externally powered up.

 

This is my cubitruk lsusb:

root@cubietruck:~# lsusb
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

And dmesg | grep usb:

 

root@cubietruck:~# dmesg | grep usb
[    0.000000] Kernel command line: root=UUID=09c47a69-3f67-4fa2-afcf-7c3abb0c17aa rootwait rootfstype=ext4 console=ttyS0,115200 console=tty1 hdmi.audio=EDID:0 disp.screen0_output_mode=1920x1080p60 consoleblank=0 loglevel=1 ubootpart=e988e4f0-01 ubootsource=mmc usb-storage.quirks=0x2537:0x1066:u,0x2537:0x1068:u   sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_fb_mem_reserve=16 cgroup_enable=memory swapaccount=1
[    1.321384] usbcore: registered new interface driver usbfs
[    1.321436] usbcore: registered new interface driver hub
[    1.321513] usbcore: registered new device driver usb
[    3.711349] usbcore: registered new interface driver usb-storage
[    3.777804] usbcore: registered new interface driver usbhid
[    3.777808] usbhid: USB HID core driver
[    5.031900] axp20x-usb-power-supply axp20x-usb-power-supply: DMA mask not set
[   16.041899] ehci-platform 1c14000.usb: EHCI Host Controller
[   16.041944] ehci-platform 1c14000.usb: new USB bus registered, assigned bus number 1
[   16.048877] ehci-platform 1c14000.usb: irq 33, io mem 0x01c14000
[   16.064658] ehci-platform 1c14000.usb: USB 2.0 started, EHCI 1.00
[   16.065028] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.04
[   16.065040] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[   16.065047] usb usb1: Product: EHCI Host Controller
[   16.065054] usb usb1: Manufacturer: Linux 5.4.35-sunxi ehci_hcd
[   16.065060] usb usb1: SerialNumber: 1c14000.usb
[   16.067326] ehci-platform 1c1c000.usb: EHCI Host Controller
[   16.067371] ehci-platform 1c1c000.usb: new USB bus registered, assigned bus number 2
[   16.067864] ehci-platform 1c1c000.usb: irq 38, io mem 0x01c1c000
[   16.080568] ehci-platform 1c1c000.usb: USB 2.0 started, EHCI 1.00
[   16.085059] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.04
[   16.085087] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[   16.085100] usb usb2: Product: EHCI Host Controller
[   16.085113] usb usb2: Manufacturer: Linux 5.4.35-sunxi ehci_hcd
[   16.085121] usb usb2: SerialNumber: 1c1c000.usb
[   16.087695] ohci-platform 1c14400.usb: Generic Platform OHCI controller
[   16.087742] ohci-platform 1c14400.usb: new USB bus registered, assigned bus number 3
[   16.088243] ohci-platform 1c14400.usb: irq 34, io mem 0x01c14400
[   16.153009] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.04
[   16.153027] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[   16.153035] usb usb3: Product: Generic Platform OHCI controller
[   16.153042] usb usb3: Manufacturer: Linux 5.4.35-sunxi ohci_hcd
[   16.153048] usb usb3: SerialNumber: 1c14400.usb
[   16.155112] ohci-platform 1c1c400.usb: Generic Platform OHCI controller
[   16.155152] ohci-platform 1c1c400.usb: new USB bus registered, assigned bus number 4
[   16.155575] ohci-platform 1c1c400.usb: irq 39, io mem 0x01c1c400
[   16.216894] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001, bcdDevice= 5.04
[   16.216910] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[   16.216918] usb usb4: Product: Generic Platform OHCI controller
[   16.216924] usb usb4: Manufacturer: Linux 5.4.35-sunxi ohci_hcd
[   16.216931] usb usb4: SerialNumber: 1c1c400.usb
[   16.219264] usb_phy_generic usb_phy_generic.0.auto: usb_phy_generic.0.auto supply vcc not found, using dummy regulator
[   16.220098] musb-hdrc musb-hdrc.1.auto: MUSB HDRC host driver
[   16.220135] musb-hdrc musb-hdrc.1.auto: new USB bus registered, assigned bus number 5
[   16.222034] usb usb5: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.04
[   16.222051] usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[   16.222058] usb usb5: Product: MUSB HDRC host driver
[   16.222065] usb usb5: Manufacturer: Linux 5.4.35-sunxi musb-hcd
[   16.222072] usb usb5: SerialNumber: musb-hdrc.1.auto
[   35.963846] usb0-vbus: disabling

 

Any advice??

 

Thanks!

Link to comment
Share on other sites

Order Armbian Linux merch!

57 minutes ago, pinballwizard said:

I am powering the board via USB

 

This is the problem which would be clear at once if you told us ;)  Moved to "SD card and PSU issues" subforum.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...